Jump to content

Out Of System Resources error PCLink


Recommended Posts

Made an own thread about my PCLink problem


Ok here's my problem:

We haven't upgraded or changed firmware, software, computer or anything in a year. We have just used the stuff.

This is what happened:

When I tried to load a log from the last race to view it (we had already viewed it several times before on the same computer) i got he message 'Out of system resources' Same thing happens when I try to load a map or layout.

The program hangs and can't be shut down

If I load one of the maps in the original 'Base Maps' it works. And after I have loaded that map I can load

one of my maps and it works. But if I then try to load my own layout I get the 'Out Of System resources' error message and it hangs. If I then load the 'Default layout' it works. If I load the 'DefaultLoggingLayout' I get

the error message.

All this with PCLink running on a Windows 7 laptop


I copied all the files and tested them on another computer that has PCLink installed

and I can't get any error message on that computer in any way, everything works. (Windows XP)


Tried the same thing on a computer at work that has the latest PCLink installed and there we got the error message exactly like on my laptop.


And we have had this problem before on another computer with an older version of PCLink. And Windows XP.

Doesn't do any difference to reinstall PCLink


I have attached my files



Link to comment
Share on other sites

Hi Fredde,

I have answered you in the other thread also:

It sounds like some of your layouts may have been corrupted. If you re-install PCLink the layouts directory does not get overwritten, this is why just re-installing PCLink will not fix the problem.

You will need to delete the whole PCLink directory and then re-install PCLink.

Give that a try and let me know if it now works for you,


Link to comment
Share on other sites

Hi Fredde,

This is not something we see happen very often, and without being able to re-create it here it would be difficult for us to fix such a problem.

It will be some combination of the settings in your map, firmware version, PC Link version, Windows version, changes made to the layout.

I will get someone to try here to see if it happens for us.

Hopefully this is the last time it happens for you!


Link to comment
Share on other sites


Last few days i have been searching for info on standalone ECU's. The Link and Vi-Pec products are available here in Sweden and have a very good reputation.

So i have been trying out the tuning software from many vendors of ECU's. All have their own strengths and weaknesses.

On to my observations:

The latest Link tuning software has a bug that throws an error when trying to load a log file. 'out of resources'.

First computer i tried it on was my desktop windows 7 64 bit machine. And just a moment ago i tried it on my tuning laptop, a acer aspire one windows xp 32 bit machine. The laptop has been worked flawless for years.

The PClink software throws the same error on both machines. So i figured i will try the earlier version of the software. Still throws the same error.

Strangest thing it works perfect on the vi-pec version of the software. It can also load the Links version of the 'drag' log without a hassle.

I have been programming since 1985 and do extensive work on the stock 6G Mitsubishi ECU's.

So i have a gut-feeling that this error must be related to your software. My guess would be that it has a resource hog somewhere just around the transition from ECU to Log window routine.

I have tried the software on machines that never seen the software before. Fresh installs.

If you need me to assist with screenshots or anything else i am glad to help.

As of now this bug is holding me back from ordering the Link ECU since datalogging is a crusial part of my toolbox.

We have great suppot for the Link products over here in Sweden so i hope you will resolve this error really soon.

Best regards, Kim H.

Link to comment
Share on other sites

Hi again!

I just found a workaround for the error. No permanent fix but it makes the software work.

We up here in the nordics have different delimiters for numbers.


US format = 100.00

Euro format = 100,00

See the difference? We have a comma as default in windows as aside from you guys have a period as default. That is what messes things up. It's a pretty common mistake among programmers to set adaptive regional settings. Don't worry, even big software makers do this mistake often.

So here's the temporary fix:

1. Click Start button -> Control panel -> Regional and language options.

2. Now choose English (USA). Click Apply.

3. Start PClink software and enjoy! :)

This is just a workaround and i still think that the software should be looked at to be adaptive to national settings. The output format should remain the same but some sort of debuging in needed to prevent the software from crashing because of such a small coding error.

Sincerly, Kim H.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...