Jump to content

PCLink can't connect to the ECU


Javier Sanchez
 Share

Recommended Posts

Hi,

I've a problem, PCLink can't connect to the ECU. It is a Link G4 fitted to a Nissan S13 with Ca18det engine.

I've installed the PCLink, connected the Ecu to the computer, and then, Windows 7 have found the LINK and have installed it correctly

a>

I can find LINK in my laptop if I have the key of the car in ON, but no if I have the car OFF, obviusly, is it correct.

But then, in PCLink I can't connect to the ECU,

The message I have is this:

a>

I've tried

- Three diferents laptops

-  Change the port com number ( Some ports) like you said here


'When you have the ECU connected to your laptop and the ignition on, open Device manager and have a look under ports and see if your ECU is listed there. If it is not and you have all your connections correct, try another USB port to be sure.

If it is listed in device manager check the com port number it is on. you can then open PCLink, click options > connections and set the serial port number to match the one in device manager.

If the ECU still does not connect, right click on the ECU in Device manager, select properties > port settings > advanced > and change the com port number to a different one, preferably one with a number of 8 or less. Change the com port in PCLink to match the new one you have set in device manager.'

 

- I've tried to update the firmware, but the answer is this:

a>

 

What happens?

Thanks a lot,

Javier Sánchez

 

 

Link to comment
Share on other sites

On the board there is a (very small) LED that will indicate if the ECU is powering up. If this is not coming on with the key it shows the ECU is not getting power.

There are a couple of pins to check., Pin 36 should have 12V at key on this then lets the ECU switch a ground to pin 4

If pin 4 is not pulling to ground it will not power the ECU.

If Pin 36 is not getting 12V it will not switch the ground for pin 4

Link to comment
Share on other sites

Woops I got the wrong header, I was refering to the Short header.

On yours being the Long header you should check pin 45 for 12V at key on 

and pin 16 for ground at key on.

When pin 16 is at ground pins 49 and 59 should get 12V

Link to comment
Share on other sites

Problem solved Simon,

Thanks a lot

One of the connectors of the fuse box dind't fit propperly, so now I have the ecu with the green led ON and connected to the PC.

So sorry, but I have two questions more.

Link pinout and Ca18det pinout are too different.. The most of the pins are changed and some of them that the CA don't use, the link yes. My questions are:

1. How can I wire CAS and TPS? I've seen something in PCLink Help file but I don't know if link use the standard pinout of the ca18det for the CAS and TPS

2. I've added an IAT sensor, AN Temp 1 is engine water temperature; AN Temp 2 is free, but CA doesn't have PIN in 55, so, have I to fit the pin in 55?

 

Thanks

Javier Sánchez

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...