Jump to content

Unable to connect to ECU, Mitsubishi EVO PnP

Dalibor R

Recommended Posts


I have a Link G4 PnP for Mitsubishi Evo 5 and I have trouble to connect to the ecu.

I had it mapped in febrary and after that was the car stored until the season started here in Sweden. 

I have tried to re-install PCLink and the USB-drivers but nothing.

I have also tried Windows Vista, 7 and XP but the computer can not find the USB.

Any ideas?

Link to comment
Share on other sites

First thing to check is if the PC is seeing the ECU in device manager it should assign it as a com port.
Make sure there is no ! mark next to it.

I assume the ECU is powering up and car still start?

Also make sure you do not have anything connected on the CAN/Serial connection of the board.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...