Jump to content

3ur-fe tundra 5.7 e-throttle probs


Recommended Posts

Hi guys. Running an old silver xtreme with 4.10.2 and can't get the throttle to work properly. It's giving me a error 4 max dc 80%. I tried shutting off the e-throttle and cycling the throttle flap. Noticed that the sub isn't changing voltage. Also tried switching the sub and main. As well as tying both sub and main to one wire to see if that would fix. No luck. Any suggestions? Also pid suggestions would be great.

Thanks for any help on this. I'm beginning to think I need a new throttle body. 



Link to comment
Share on other sites

Few things to check.

Make sure the fault settings on the AN volt inputs are clear of the voltages being seen from the throttle.

On the Toyotas the TP sub will only span to about 70% of the main which will cause issues so will need to use the TP main signal to feed both inputs. (G4+ fixes this)

Check throttle moves in correct direction when doing the calibrate it should close then open fully.

IF you start with lowish PID figures it should be enough to do the cal process and then you can refine them later.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...