Jump to content

Can't connect to ECU (WRX4+) via PCLink


SamW
 Share

Recommended Posts

As title, I haven't been able to connect to the ecu on PCLink, it power up and still runs the car etc. I have tried un-installing/re installing, drivers etc and have just tried a second laptop with a fresh copy and I still can't connect

 

any ideas?

 

thanks 

image.jpg

Link to comment
Share on other sites

Main things would be making sure the ECU has a full 12V supply and the green LED is coming on on the board.

Check the CANPCB (200mm) cable is fully inserted in to the connector on the ECU and its terminals are seated correctly in the plug.

Also make sure the ECU is showing in device manager and has no warnings.

Link to comment
Share on other sites

Green LED is coming on and is showing in device manager, all drivers up to date which is what led me to believe initially it was a software problem but PClink recognises that it cannot connect to the ecu even though something is there. I'll have another nose at the cable, last time I checked all pins were seated and plug in there solid etc. 

 

Ill have another go later, thanks :)

Link to comment
Share on other sites

If you try to run firmware update (this can be done with out PC link being able to connect) what happens?

Also you could try powering the ECU up on the bench with just power and ground to see if that will let you connect.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...