Jump to content

MR2 Link Coil on Plug Conversion


Recommended Posts

Hey all,


Having some trouble with a coil on plug conversion.

Running a Gen 2/3 MR2 Link on my Gen 2 3S-GTE.

It's had the electronics swapped to Gen 3 and ditched the AFM


I purchased a RacerX Coil on Plug conversion kit for it, running 1ZZ-FE Coil Packs, with a 36-1 tooth crank trigger wheel and 1 tooth cam trigger.

This came with a pair of 3-wire Cherry Hall sensors designed for this purpose, see following link:


We already know the engine runs fine, it was first tuned running the factory distributor and intercooler. Now has a W2A setup and the aforementioned coilpacks.


The issue I've run into is that when changing the ignition type to Direct Spark for the coil packs, we're getting no trigger signal from either crank or cam sensors.

I've checked the wiring according to the ST205/MR2 manual and wired it according to what's online:


Blue is ground, running to ECU ground (pin 46 on ECU)

Brown is supply voltage (running 5V supply from ECU, Pin 38)

Black is signal to ECU (to triggers 1 and 2 on the ECU, pins 10 and 22 respectively)

I've checked the wiring from sensors to the ECU, they're getting power and supplying signal, but the ground on both of them is getting nothing

Even running a resistance check from the ground wire to the chassis directly gets nothing from either sensor.


I also purchased a brand new one to be safe, same result


Any suggestions as to why the earth on all of these isn't picking up and why the ECU isn't picking up a trigger signal from either sensor?


Any advice would be fantastic. Once it runs again, I'll be replacing the P&P with a wire in Monsoon to tidy up the engine bay, but would rather the wiring is done right before i replace it



Link to comment
Share on other sites

Pin 46 should definitely be acceptable as a sensor ground.  It is more common to power those sensors from 12V as 5V could be a bit marginal but lets check a few other things first...

Have you checked there is continuity from pin 46 at the ecu to the blue wire at the hall sensor?

Can you post up your map so we can check settings.

Link to comment
Share on other sites

There appears to be no continuity between Pin 46 and the blue wire, no.

We checked all 3 when first attempting to start and both others got a signal with the multimeter, ground gets nothing.

I'll post a screencap of the settings currently used (I didn't set this up so could use some help there too) tonight.



Link to comment
Share on other sites

Can the sensors ground to the chassis or do they HAVE to be to the ECU?

If it has to be to the ECU, I'll rerun the wiring and see how that goes.

Also, according to the diagram, there's no 12V, would the 14V supply be okay for these sensors, just to be on the safe side?


Thanks for your help!

Link to comment
Share on other sites

There are some interesting numbers in that log.

MAP is reading 280kpa - and it moves a little bit when you crank the key so it looks to be wired up to something.

Throttle position = 100% the entire time

Engine temp = 100deg C

Have you got all these sensors wired up or just a few things to get it to crank over? Have you changed any other wiring apart from the coils and triggers since it was last running? 

Where i'm going with all of this: it appears that there may still be a wiring issue and some of the sensors are being fed voltage on the wrong pins causing them to report maxed out readings. If this wiring issue is also impacting the crank signal it wont work.  Most of the sensors with bad readings are probably 5v though. Did you follow AdamW's suggestion to run the crank trigger off a 12v/14v line? Does anything else attach to the same 14v line, or the crank signal wire, or the ground you are using for the crank trigger? 

Posting a log of the trigger scope function while cranking it may help.

Link to comment
Share on other sites

Hey CJ,


there are some interesting numbers indeed.

All of these were working correctly before I did the coil on plug conversion, as it had the initial tune done with the Distributor.

the only things I've changed have been according to the MR2 Link manual for Gen 2-3 manual, which is adding coilpack signal to pins 20, 7, 8 and 17 for ignition signal, and triggers to pins 10 and 22.

as well as supply voltage for all, and earthing.

the coilpacks themselves aren't firing right now, but that's irrelevant and expected as we aren't getting a trigger signal yet


I'm still running the triggers from the 5V supply as of now as ran out of time last night before it got dark, but it's definitely getting power as I'm getting a complete circuit and am now earthing to chassis.

have double and triple checked the wiring pinouts compared to my wiring, the ECU earth itself doesn't appear to be functional for unknown reasons.


Something I thought of last night was that I may actually have a Gen 1 MR2Link, as the pinouts are different for some of the ignition wiring and and trigger signals, but that doesn't line up with the readings we're getting as shown above either.


I am somewhat tempted to just pull the entire mess of a loom and just redo it with the A-Loom I have sitting here ready to go for when I change to a Monsoon, but would rather it all works before I waste my time and it doesn't function.



Link to comment
Share on other sites

The link guys can probably confirm from the serial number which version you have, but looking at the pinouts you could check it yourself by running the ignition tests. on a gen2/3 you should hear each coil fire when you run the test for it. If you've actually got an ecu for a gen1 you wont be able to fire 3 of the 4 coils as it doesnt look like ign2-4 are connected to any pins.


If you're still feeding the trigger sensors off 5v, and the only wiring you've touched is the trigger and coil pins then its possible the trigger sensors are wired wrong and are letting 5v onto what should be the signal ground wire or similar. Can you connect a laptop, turn the key to on so you can see MAP, TPS values etc, then physically unplug the connectors to both trigger sensors? if your MAP and TPS both jump to normal values once these are disconnected then the problem is in how those triggers are wired. If nothing changes then your wiring problems are elsewhere and I need to think about it some more. It seems very conincidental that you're trying to run new triggers off the 5v supply, and other things on the 5v supply are now showing bascially 5v constantly rather than their actual values.

Just to be clear, you had this exact ecu, with 90% the same wiring, and a very similar config running this car previously?

Link to comment
Share on other sites

well I can't hear the coils firing as they have no signal going to them as the triggers aren't working so they aren't getting any signal to fire, but I see where you're coming from there.


I'll try your test and disconnect and see if they provide the same result. they aren't plugged in at that point per se, I can still just pull them and disconnect, supply and trigger are just bullet lugged at the moment in lieu of deutsch connectors which will be going on once the new loom is done.

I'll also see if it makes any difference running from the 14v supply as well, maybe that'll make a difference too.


and yes, to confirm, the car was running on this ECU, with the same tune, same wiring, only difference was it had factory dizzy, no coil packs or cherry hall sensors. In saying that, I had to cut 4 wires on the "factory" loom (it has a patch loom for the gen 2-3 elecs swap that required work in itself) to run for the coil pack signal, but as far as I can tell on the diagrams, those wires went nowhere once the ECU was installed.

I even cross checked the two pinouts from Gen 1 to 2-3 and none of those pins I've used match up to the readings I'm getting

also the intercooling, as it's got a W2A setup now, but the only electrical there is the water pump at the front end, which isn't even wired up yet.


Also, as I mentioned before, I'm getting no continuity from sensor ground (pin 46), but do from the chassis, hence why these 2 sensors are earthed to the chassis right now.

Link to comment
Share on other sites

You can manually fire each coil using the ignition tests. No trigger signals needed, just click the one you want and listen for it clicking. Its also a good way to check you've got them wired up to the correct cylinders.


Link to comment
Share on other sites

4 hours ago, MatterCompressor said:

Something I thought of last night was that I may actually have a Gen 1 MR2Link, as the pinouts are different for some of the ignition wiring and and trigger signals, but that doesn't line up with the readings we're getting as shown above either.


Note it should be pretty easy to tell what version ecu you have, it will be printed on to the ecu bottom board, either ST185 or ST205:



1 hour ago, MatterCompressor said:

Also, as I mentioned before, I'm getting no continuity from sensor ground (pin 46), but do from the chassis, hence why these 2 sensors are earthed to the chassis right now.


If you dont have ground on pin 46 then you have something wrong with your loom.

The ST185 should have ground on the following pins: 1,14,26,39,46.

The ST205 should have ground on the following pins: 13,14,23,26,46.

All of those pins eventually connect to the same ground plane in the ECU so if 46 isnt showing a ground it can only mean 1 of 2 things - either none of those pins are grounded or you have fried a track off the PCB.  


Where abouts are you in the world?  It sounds like you might need help from a professional.

Link to comment
Share on other sites

I'll pull it out of the case and double check what one it is to be sure then.


and looks like I may have to get someone to take a look at it

I'm in South Australia, and it was first tuned by a guy who knows Link ECU's fairly well, so I'll ask him and see what the deal may be.


Thanks for the advice!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...