Jump to content

SR20 VET First start up


David SR20VET
 Share

Recommended Posts

Hi

Yesterday and again today we setup the base timing for a nissan SR20VET. Base timing was set to 10 degrees and the offest to match this on the timing light was -17 degrees. Trying to start it here is unsuccessful. It is sparking but back firing out the exhaust. We adjusted to -40 degrees and seems to closer to starting however it it will not start.

The fuel has been reduced by 66% as the injectors are 3 x larger than the stock injectors. Attached is the base map we are trying to use with it set back to the -100 degree offset. Any advice would be appreciated.

Start up map 30.10.2017 with mixture map reduced fuel.pcl

Link to comment
Share on other sites

If your timing shows correct with a timing light but it is backfiring then that would indicate you are out by 360deg (firing on exhaust stroke rather than compression).  Try adding 360 to your offset. That would be about 343deg.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...