Jump to content

Delphi pencil coil pin layout


fiestacosworth
 Share

Recommended Posts

Hi. Can anybody confirm for me the pin layout. With an imagine as nothing is written on my coils! For Delphi GN10370 

attempting 1st start are the AI1 - AI4 on the bottom of the aux tab on configuration screen suppose to be on ? As they say off. Thanks 

link monsoon on a Cosworth YB engine running direct spark. 

Injectors are working fine. I removed a coil and fitted a plug in the end. No spark. 

Thanks

Link to comment
Share on other sites

http://www.highliftmedia.com/guides-technical-info/honda-k-series-coil-on-plug-cop-wiring-diagram-pinout-how-to/

Ignition drives should look like below, if not you either have an ignition setting wrong or your not connected to a live ECU.

PkZoa0W.png

 

Easiest way to test coils/wiring is go to >ecu settings>ignition setup>ignition test.

Link to comment
Share on other sites

Thanks for that response! I’m very very confused and annoyed!!! 

This is exactly how I have my coils wired as. And 1 ecu 2 earth 3 +12v  100% the same as in the link. 

I run an ignition test in PCLink and the coils click away. Car starts runs like crap. However the coils brand new!! Have all burnt out!! Completely burn out melted! What’s that all about ? 

Also what’s even more annoying is every time I try to login to this forum I have to rest my password! Driving me mad. 

CA1621B0-3DA8-4D12-B5C5-96186047F30F.jpeg

Link to comment
Share on other sites

Hi mate. Yes had it set to falling as per the other post I have on here that you replied too. Was doing initial setup just going thru everything. No firmware being run at that time. Literally sitting with ignition on and connected to PCLink. 

I have them wired as per the diagram ignition coils running from there own fused relay pin 3 Earth going to cylinder head pin 2 and pin 1 going back to ecu for each coil. They worked when I tested them on PCLink could here them clicking when testing. And vehicle started and run! No external igniters. These coils are defiantly 12v and not 5 ? 

Then on Sunday morning went back down to check a few things. Turned the ignition on and about 5 mins later could smell burning! And that was the result. I’m so confused as to what could of caused this! Faulty coils ? 1 I could get. But for all 4 to be faulty is unlikely. They was brand new. PCLink throws up no faults. 

Wrong spark plugs ? “Original Cosworth ones” causing too much resistance ? 

I am confused as if this had happened with the engine running it could be because of dwell settings etc right ? But it was off with just Ignition on ? 

I have bought another set of coils. But don’t want to plug them in invade it does the same again. 

Link to comment
Share on other sites

Also before I fitted this. I was running wasted spark on omex. And I never had any problems with The coilpack over heating or melting! Point being surely it can’t be a high resistance earth fault if the fault never occurred before. And the chassis / engine earths haven’t changed. Apart from the earths run from my monsoon. 

Link to comment
Share on other sites

Provided the ignition outputs were assigned as "ignition" and the spark edge was set to falling then when you are sitting there with ECU on/eng off the ECU should have just been outputting a ground to the coils full time.  Normal falling edge coils should only charge when the high dwell signal is received i.e coils should have been off the whole time).  I looked at quite a few "K20" maps from customers in our database (same coil I believe) and all have spark edge set to falling so I'm fairly sure this is the correct setting for these. 

Sparkplugs and grounds and all the other stuff you mentioned shouldnt matter as coils should have been off.

Maybe you can start with this basic test to confirm if ECU is doing what it should be:

With coils unplugged, ignition turned on, engine not running (lol good luck running it with coils unplugged!), check with volt meter between ignition output pin and ground.  It should read close to 0V.  if it is showing 6V or something we have a problem. 

Report back what you see when doing this test.  I will ask Simon to have a look at this thread tomorrow and see if he has any different thoughts to me or suggestions.

 

Link to comment
Share on other sites

Ok just went into pclink and it was set to rising.!!! £150 down the pan! How annoying. 

This was the initial setting the ecu was set to so the damage was done on Saturday when I 1st had the ignition on. Hence why it run like crap they was already burnt out! 

Live you and you learn I guess. Least I know what caused it now. 

If I send you my spec would you be able to send me over a base map so I can get it running to take it and get it mapped ? 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...