Jump to content

3SGTE MR2 COP G4+ PnP Tacho


Recommended Posts

Hi Gents,

I need help! 

I followed all the info available on the web, including this: 


Basically, I cannot get my rev counter to work. The ECU is outputting a signal, there is continuity between the cable linking the ECU to the rev counter on the back of the cluster. The resistor is soldered and working fine, showing 1Kohm. But When ignition is switched on the needle moves a mm and thats it. The ECU was setup with a base map, but then there were boost issues, so it's not going back to the mapper until they're sorted, I'm trying to get all the niggles sorted, this being one of them. 

I'm fairly new to ECU setup, so please excuse me for being a complete novice. Much easier working with nuts and bolts :-)

Here's a screenshot of what I have on the Link console. This may be normal, but why do I have tacho appearing under fuel pump control and Auxiliary outputs? Should it be in both places? There are settings available when clicking "Tacho" under the fuel pump control, but no settings available other than changing the designation of what it is on "Auxilliary Outputs" .

Apologies if this is a total newbie question, but I've tried searching to no avail over the last couple of weeks! :-) 

I think that's everything, there is voltage coming from the wire from the ECU to the Tacho wire. Now I've seen it appears in two places, I'm wondering if it's wired to the wrong pin. But I didn't wire that! :-)


Screen Shot 2018-12-03 at 12.46.41.png

Link to comment
Share on other sites

We had the same issue when we put a monsoon on an AE86 (JDM digital dash) with a 4AGTE conversion, no rev counter.  The only mod i did was to piggyback a 30k resistor onto R4 ( which is in series with the input signal).  This fixed it and rev counter has worked fine since. 

Image result for toyota rev counter resistor





Link to comment
Share on other sites

Thanks Richard. Is that diagram the plug on the back of the clocks? The thing that confuses me is I've done as everyone else has done yet mine doesn't work. I've replaced the signal resistor for a lower level so it can receive a lower voltage, i.e. from the ECU not the igniter.

Well as per the pictures in the thread linked above. I haven't added the pull up resistor as it seems people haven't. 


Do the settings on the ECU look correct?

Link to comment
Share on other sites

It was a while ago so i'll have to try and remember.  That schematic is for the circuit diagram inside.  T2685A chip is the tacho interface (frequency to voltage converter IIRC

 Image result for t2685a


The settings in your map look OK. They look the same as I used.



What Aux out is the Tacho wired to?  And is it set to tacho in pclink?

Link to comment
Share on other sites

Thanks gents, so, I sorted it, I was using an expansion loom to provide tacho out which is 5v's. I used the pull up resistor on the board and used another spare on the expansion loom to increase voltage, so there are two wires from the expansion loom driving the tacho, one is assigned as tacho, the other isn't but works perfectly. Not sure if that's right or wrong, but it works and is accurate. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...