Jump to content

rx7 engine dies intermittently on off throttle


Zensation
 Share

Recommended Posts

Hey,  I have an issue where My car will die at idle rpm (around 1000 rpm) when coming to a stop sign sometimes or on off throttle after a pull.  I havnt dug really deep into the issue yet but I was hoping someone might have some insight on where to start.  I went for a short drive tonight and I have attached the log file here.  you can see sometimes the car shuts off and I just start it back up.  I dont have an IAC valve and its an rx7 single turbo.   

drive.llg

Link to comment
Share on other sites

It looks like it is mostly ignition timing related, you have about 10deg at normal idle, but when RPM drops below normal idle the MAP increases so the timing drops to 5deg which just makes it fall over.  Since you have no IAC you should flatten off the ignition table in that area and also enable the idle ignition control.

Also, your log shows 7ms dwell is commanded at all times - that doesnt sound right, what coils does it have?

Link to comment
Share on other sites

Thanks Adam I will look into that.  As far as the coil dwell, I have a dwell map that varies with boost i will update it with, i set to all 7s when i was debugging my previous issue we communicated about which turned out to be stuck apex seals and required me to rebuild.  So far I have limited the rpm and boost so the 7ms everywhere should be fine.  Im running the IGN1a Coils and at 8000 rpm i can dwell them around 4.5ms in direct fire and still be ok.  

Link to comment
Share on other sites

  • 3 months later...
On 12/9/2018 at 3:17 AM, Adamw said:

It looks like it is mostly ignition timing related, you have about 10deg at normal idle, but when RPM drops below normal idle the MAP increases so the timing drops to 5deg which just makes it fall over.  Since you have no IAC you should flatten off the ignition table in that area and also enable the idle ignition control.

Also, your log shows 7ms dwell is commanded at all times - that doesnt sound right, what coils does it have?

Hey Adam thanks for the input, Im still having issues with this.  on starting the car on a hot start the car seems to be idling low rpm and a little rich and acts like it wants to die unless i give it throttle but when its hot there are no enrichments enabled like warm up or post crank enrichment, after it gets going about 30 seconds to a minute it starts to idle fine around the 1100rpm mark.  where could the extra fuel or idling issue b coming from.  also i did some adjusting to the idle ign control table but the car still wants to die on closing the throttle and i drove it about 30 miles today fully warmed up and 3 times it died when i go into neutral and just cruise.  I have attached a log of the hot start issue where i give it gas and it dies when i let off the throttle, as well as my current tune if you can take a look.  also i replaced the oem throttle body with a 90mm rotary works throttle body.  id really rather not use an IAC valve if i can do without it.

G_rev4.pclr 4.7 hot start off throttle issues.llg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...