Jump to content

Link plugin G4+ connection issue to laptop driver related


Recommended Posts

I have recently purchased and installed a LINK g4+ plugin for my FZJ100.

I have installed exactly as per instruction including driver instructions, (and re-installed countless times), checked the connection of the lead on the ECU as per other threads here with similar issues, however the laptop still has a yellow warning icon the LINK device when plugged in to the usb port.

It sees that the device is connected, and knows what it is, but it is not usable through PC link as it has a driver error.

when i manually try to install the drivers from the drivers folder in PC link folder, it states drivers up to date, and will not install them.

im using windows 7 64bit.

Any advice? i can only assume its a windows setting related problem to the drivers, or assignment of them but im stumped.

thanks in advance



Link to comment
Share on other sites

I've seen something similar happen twice recently, they were both Windows 7 also.  I logged in to the customer's laptops myself and couldnt get the Link driver to work correctly either.  Here's how I fixed it:

Go here and download the VCP driver that matches your OS - you will want the Win 7/8/8.1in this case.  https://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers

Once downloaded, unzip it and install it.  Then you need to force the Link ECU to use that Silicon Labs driver in device manager.  Here's a quick video showing how to do that:  https://1drv.ms/u/s!AiYbYlZQuRHPonzbvTGle78-UlcH 

Let me know if that works.  We updated the USB driver that is included in our installer in the latest release and Im starting to wonder if it may not be compatible with Win 7.  I will do a bit of testing next week.

Link to comment
Share on other sites

PC Link 5.6.6 does not pick up the USB drivers for Windows 7 on install.  You need to install PC Link 5.6.5 first which will install the USB drivers properly and then install 5.6.6 over the top.  It is a problem I reported last week, and has now been confirmed by Link as a 5.6.6 bug.




Link to comment
Share on other sites

Thanks again guys,

I tried another laptop (also windows 7) but had exactly the same problem,

i was in a hurry so i did as you suggested Richard, downloaded PC LINK 5.6.5. 

the drivers installed correctly and connected without a problem! on both my windows 7 laptops.

I then installed PC LINK 5.6.6 but pressed cancel on the driver installation prompt, now all is working fine.

Thanks Adam and Richard for your help!




Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...