Jump to content

ecu hold power problem


Recommended Posts

i have ecu hold power problem with storm black on evo7. ecu hold power is use for the evo7 idle function.

when it is working fine idle rpm is good after engine restart.

when it is not working ecu hold power remain active for more than 15sec, idle valve rattling sound for a long time, after engine restart rpm goes up to 2.5k as idle valve remains large opening.

attached are logs for when it happens

ecu hold power good.llg ecu hold power no good.llg

Link to comment
Share on other sites

Is this just a new install or has it previously worked fine a just recently started acting up?  The ECU staying partially powered up would typically indicate an aux output is back feeding.  Besides the stepper motor, what else is connected to aux outputs?

Link to comment
Share on other sites

This is a new install.

Everything is working fine just that ecu hold power would be intermittent causing 2.5k idle when idle valve would not return to their position. Most of the time it is good.

I dont think it is backfeeding as show in log file ecu hold power remains active. Ecu is holding the main relay ON.

I will email you the tune file in a while.

Link to comment
Share on other sites

Yeah, I can see whats going on but unsure what is causing it.  Basically the way ECU hold power works is like this; when you switch off ignition the ECU kills the engine by cutting spark and fuel, it then commands a "stepper motor reset", this reset is normally seen as the valve "slowly" winding fully open to 0, then winding closed to 50steps ready for the next start up.  Once the ecu sees that the stepper motor has reached its 50 step home position it starts counting down the keep alive time and then shuts off.  

In your "no good" log this doesnt happen - the valve jumps to 0 but never closes back 50 steps so the ecu stays alive waiting for that.  However, even your "good" log doesnt show the correct behaviour - when you turn ignition off rather than the valve "slowly" going to zero and back, it jumps suddenly to zero.  Im suspicious maybe the idle valve +12V is being cut with the ignition switch rather than by the main relay?

I will post a couple of pics of how a normal stepper reset looks compared to yours.

Here is the normal expected behaviour (this was done using your file in an ecu running the same firmware as yours):



Your "no good" log:



Your "good" log:



Edited by Adamw
Link to comment
Share on other sites

This would be my suggestion as a troubleshooting step:

  1. Unplug idle valve.
  2. Set ecu hold power keep alive time to about 60sec so it doesnt shut down while we are doing the tests.
  3. With ignition on but engine not running, start PC logger.
  4. Switch off ignition, watch idle position runtime, observe if it behaves correctly - winds down to zero, then back to 50.  As soon as it gets to 50, turn ign back on.
  5. Repeat step 4 say 10 times with it logging the whole time.  Save that log when finished.  We want to see if it behaves correctly with the valve unplugged or still does something odd randomly.

After that reconnect the idle valve and do that same test another 10 times with the valve plugged in to if this gives us any clues.


Link to comment
Share on other sites

adamw, i made 4 log files with idle valves disconnected and connected and while turning the engine on or off.

i found that without starting the engine, stepper reset works normal with the valve connected and disconnected.

turning the engine on and off makes the behavior becomes random.

idle valve disconnected engine running.llg idle valve disconnected engine not running.llg idle valve connected engine running.llg idle valve connected engine not running.llg

Link to comment
Share on other sites

Thanks for the logs, I have managed to reproduce it on the bench with that data, it looks like possibly a new bug that has surfaced in 5.6.6 firmware.  I tried on an ECU on 5.6.5 and couldnt reproduce it so I think it is isolated to the latest version.

Can you try downgrading your firmware to 5.6.5 and confirm if that works correctly for you, I will then have a bit more info to report back to engineering to get it fixed.  To downgrade, it is the same process as updating, just choose the older version from the list of firmwares.

Link to comment
Share on other sites

adamw, i tested firmware 5.6.5 and stepper reset is working correctly now. ecu hold power is also working correctly.

i made 2 logs with engine running and not running. with engine running stepper reset step isn't smooth but it is definitely better than firmware 5.6.6.

5.6.5 engine not running.llg 5.6.5 engine running.llg

Link to comment
Share on other sites

Ive had the same issue and figured it was something backfeeding for some reason, I now realize that I do run the newer software and have since it first came out so it could be an update issue, I just turned off the hold on the ecu to stop it because my check engine light would stay on permanently though very dimly and the ecu would not ever power down if I let the ecu fully cycle the fuel pump relay, if I turned the key off before it shut off the fuel pump by itself, the ecu would power down properly after a few seconds and after moving the idle control motor, if I let it stay on after fuel pump prime then the idle control motor would never move after key off and as I said the ecu would never actually power down, it keeps the control relay powered with less than 12v, I think I measured around 5v on the relay keep alive coil.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...