Jump to content

VR4 Link on 1G Talon: AN Volt 4 at 0.02V Constant


Recommended Posts

I have done my best to search all of the previous posts, but I can't find a solution. Here's a rundown of my vehicle:

  • 1991 Eagle Talon AWD Turbo
  • 4G63T Engine
  • Link G4+ - VR4 Link
  • Wide-band: AEM 30-2301 Controller with a digital (non-controller) gauge, factory narrow-band has been removed.

I used a pin from a spare engine harness and attached the orange 0-5v out wire from the wideband controller. I removed the NB O2 pin from the main engine harness and inserted the modified pin into the connector. This should have the 0-5v signal from the AEM wideband going to AN Volt 4 on my VR4 Link ECU. At first I got error code 20: AN Volt low or at ground. I changed the settings so that the min and max are 0-5v, which took care of the error. I changed AN Volt 4 to display 0-5V and it shows 0.02V all the time. The wideband gauge is working just fine. I checked voltage at the harness pin and it read 4V with the O2 sensor disconnected, which is what the controller defaults to when the sensor is disconnected. That was with the harness disconnected from the ECU. I also removed the pin from the harness and check voltage at the pin with the engine running. It hovered above 4V and below 5V, which appeared to be consistent with what the wideband gauge was showing. I used a chassis ground with the multimeter when testing. I have tried attaching the wideband ground  black wire and the brown differential ground wire to multiple ground locations (chassis, battery terminal, block), without any luck. I also tried all of those with the brown differential ground taped off. The reading in the ECU always stays at 0.02 V. The only test I have not completed is checking voltage of the ECU pin when the harness pin is attached. I do not have a good way of gaining access with multimeter to do this. I wanted to see if anyone has any insight on this before I pull the cover off of the ECU and attempt to test the ECU pin itself. I also compressed the harness pin just a bit to ensure it would make a good connection.


Link to comment
Share on other sites

I dont think you mentioned which pin you are using, but just to confirm, it should be pin 4 that I've highlighted below.  Another quick test you could do is connect pin 4 to pin 23 (the 5V supply) with a short jumper wire, an volt 4 should then show 5V.


Link to comment
Share on other sites

Wow, I feel like a real ass. I transposed the pins like I was looking into the harness, rather than into the ECU. I spent hours troubleshooting pin 9! Thank you for helping me help myself. One last question. AN volt 4 is now reading 4.00 V when the sensor is unplugged, but lambda 1 does not match up with 4V on the AEM sensor scale. I used the min and max values from the sensor table for Cal 4. I do not see a place to enter all of the sensor scaling values.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...