Jump to content

R32 GT-R G4+ to G4X upgrade , won't start


Recommended Posts

I just upgraded from G4+ to G4X on my R32 GT-R. and now it won't start.

The car was running perfectly fine with the G4+. no issues. 

I decided to upgrade to G4X to take advantage of the new features and faster speed. 

Car has HKS Vcam, NZ Wiring trigger, bigger injectors, turbos...etc.

I tripled checked the settings again and again, i couldn't figure out why it's not working. all the input / outputs are assigned correctly.

It's basically a copy of the G4+ settings/map over to the G4X.


It would try to fire, but barely fires up.

I can make it fire up if i hold the throttle flat, and it would idle like a diesel engine at 400-500rpm, with lots of backfires. 



Link to comment
Share on other sites

i'll give it a try tomorrow.

it's impossible to idle. it will somehow "idle" for a few seconds with throttle flat out, but will die after a few seconds. 

i'll try to log as much as i can. 

I checked the trigger setting, i have it set to the same offset as the G4+.  the settings are exactly the same. 

the G4+ didn't have the "Sync Tooth" setting, it's set to 1 in the G4X.  since it's a 24-1 trigger.




Link to comment
Share on other sites

I adjusted the arming threshold, same thing.  the scope looked a bit cleaner but it didn't improve a bit.

the drop out might have to do with the battery, it's cranking at 9v. but i had no issue with the G4+. 

i put the G4+ back in, it fired right up just like normal. 

i spent a whole day triple checking every single setting, i couldn't find anything wrong... 

Link to comment
Share on other sites

Slim to none.  Your log showed an intermittent trigger 1, your triggerscope showed trigger 1 voltage lower than the arming threshold so it would be correct for the ecu to ignore trigger 1 under those conditions.  So in other words the ECU was doing exactly what is expected in the original log/tune. 

That is why I wanted to see the new log and tune as the adjustment I suggested should have at least solved the trigger issue.  So I need a new map and log to see if we still have the same trigger setting issue, or if there is something else going on.  

I just found Jono's case in tech support and the arming threshold still wasnt set as per my suggestion above in the map he sent us so I have asked him to do that again.


Link to comment
Share on other sites

Slim to none. this is great to know

I'll give it another try tomorrow. last time i changed the arming threshold and tried to start it right away, battery was dying so i shut it down and didn't save anything. Jono sent me a new file to test as well.  will report back soon


Link to comment
Share on other sites

I tested it with the suggested arming threshold, still the same thing. no sign of life.

however, one other file that Jono did, Test1, the engine somehow started briefly, but still runs very rough like diesel and dies in a few seconds. 

i uploaded the 2 different test file from Jono, in the dropbox now. also 2 sets of corresponding scope and logs. 

Link to comment
Share on other sites

The trigger and RPM looks happy in "Test 1" at least at cranking RPM, whereas test 2 is still showing lost sync every few revolutions.

The only logic I can see for the test 2 settings not workng is there is a bit of noise in the missing tooth area that may be just exceed the arming threshold enough to cause a false tooth.  

With the "bad idle" with Test 1 settings it may be that the arming threshold is ok at cranking speeds, but since the arming threshold ramps up very quick (0.2v @ 500rpm Vs 1.5V @ 1000rpm), it may be that it is not happy once it gets to idle speed.  

I dont really see anything else wrong.

So my next thought is lets try a combination of these two arming thresholds to see if we get any different results.  

Try this:


If you can get us logs and scopes from this test it will be helpful, the scope from the last "test 2" didnt capture much, so make sure you only hit the capture button when it is already cranking.  If you can get it to "idle badly" again, it would be helpful to try to capture a log of that too.


Link to comment
Share on other sites

It kind of "Idled" at 500 rpm lol...  it sounded like a single cylinder engine.   

i'll get another log and scope today with the new settings. 

what puzzles us is that, the arming threshold was the same on G4+, and it runs perfectly fine. 

Is G4X more sensitive to noise in some way?

Link to comment
Share on other sites

Thanks, you have caught what I wanted in the triggerscope this time so I can see the reset.  I will have to pass this on to the firmware team for some thoughts as I dont see what is causing the lost tooth count.  It looks like the crank suddenly speeds up just as the missing tooth is going past the sensor and it gets missed.  But I will confirm when they come back to me.   

The 2psi when cranking was just a very short spike so looks like a small back fire.    

Link to comment
Share on other sites

One of the firmware engineers only had a very quick look before he left tonight and the first thing he said was same as me "crank sped up dramatically".  But that was just based on the one latest scope and wouldnt explain the bad idle as crank speed should be more stable then.  G4X in my experience is also far more tolerant to cranking speed variation than G4+ too so that doesnt explain why G4+ is happy.  He is going to have a deeper look tomorrow.

In the mean time a couple of other things that may be helpful if you have time:

Set up ECU logging like my pic below, this will give us some more detailed logs than PC logging.

Set ignition mode to off and do us a new triggerscope or two while cranking, that will eliminate any big speed changes due to firing or kick backs.

After you have done that new scope then go to >logging>ECU log file download and download all files that are in there.


Link to comment
Share on other sites

Uploaded 2 trigger scopes and the ecu log files.  I just downloaded the files as is after enabling ecu logging and setting those parameters.

I didn’t attempt to start it . let me know if you want me to do the logs in any specific way.

they are labeled as 2021-02-17

Link to comment
Share on other sites

Thanks, we still dont have a good explaination of what is going on.  In one of your triggerscopes the firmware engineer can see the missing tooth gap has been mis-detected due to the crank rapidly speeding up right where the gap is which could explain the starting difficulty.  The G4X does an extra validation check after the gap which the G4+ doesnt do which may be some of the difference.  But that reason wouldnt likely apply once the engine was idling and the crank speed was more stable so we are not convinced we have found the real problem.

I will PM you a special firmware to test that has a loser tolerance on the gap width that may help.  Install this like any normal firmware update, just use the browse button in the firmware update screen to choose this file.

It would be really helpful if we could get a triggerscope capture when the engine is "idling" or closer to idling - I dont know how likely or easy that is for you, but please give it a go.  It may start easier with this new firmware.  

Can you also get a couple of triggerscopes when cranking (with fuel/ign on), with two variations of "Ignition Idle Target", It is currently set to 10deg, I want to try 0 and 20 to see if that moves the crank acceleration away from the gap a little.  You will find this setting in >Idle speed control>Idle Ignition Control.




Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...