Jump to content

WRX2X G4X not responding to Haltech WB1 via CAN


Recommended Posts

Hi 2gether,


i have a little Problem.


I had a Costumers Impreza in the Shop and we fitted a Brand-new G4X. All wiring goes perfect, IAT and Mapsensor work and the car starts. But we don't get a Connection to the Haltech Lamda Controller via can. I used the CAN to PCB cable and the Haltech Adaptor, wired 12v and ground. Set the Can Setup correct to Userdefined and, Channel, LINK Can-Lambda and ID950 (other IDS tried) but when I hit "Find Devices" nothing Shows up. Have tried another, definitely working WB Controller, same problem. The Runtime Values for the Can Port don't show any Problems. I also tested the connection between the CanHi and CanLow Pins of the cables, all fine. 

Can anybody help me? Is there a hidden feature I had to activate?


Thanks for your help.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...