Jump to content

v88 trigger 1 input. Nothing registered.


Recommended Posts

Stopped at a gas station in Germany, filled up the tank, started and drove 10m or so, idle for about 30min. Stopped engine, and when we were supposed to drive on there was no life. Turning the engine with no input on the trigger. Have tried Hall and Reluctor trigger without any success. Went over the wiring and ground points, everything measures and looks good. Live feed while turning the engine shows 0 rpms... Updated to latest firmware 4.10... still no luck. Any ideas? Does anyone have a printout of the PCB circuitry of the trigger 1? So i can check for anything fried... Or is there some workaround so i can use the trigger 2 input. Btw, i'm using the motronic 60-2 trigger wheel.

Stranded in Keula/Germany so response ASAP would be appreciated!

Link to comment
Share on other sites

Hi SNAKE ___1,

I am sorry for your situation.

So the engine has been running fine and then it has just stopped, you have no trigger 1 output and therefore no rpm signal.

You obviously have a laptop to know these symptoms and to do a firmware upgrade,

Can you press R or F12 on your keyboard to access RUNTIME VALUES, go to the triggers tab, crank the engine and check the trigger 1 and 2 signals and check for trigger error counter.

Then go to the ECU STATUS TAB, check all of the ECU VOLTAGES make sense.

You say you tried HALL EFFECT and MAG reluctor, do you mean you physically changed the sensors or changed the software sensors type.

What type of sensors do you have on the engine for Trigger 1 and trigger 2



Link to comment
Share on other sites

Yes i have a laptop and already checked the trigger 1 status. No signal. Nothing happening. Yes i purchased 2 new cranksensors from a local dealer here. Reluctor BMW 325i 1993 M50 engine and one hall BMW 328i 1997 M52 sensor. No luck. Every voltage looks fine aswell. +5v = 4.95v inernal 12v = 11.98v so on so on...

Running wasted spark so i don't have a trigger 2...

Link to comment
Share on other sites


very strange.

Are there any fault codes.

Are there any loom connectors partially dislodged.

Wiring loom rubbed through or similar.

I don't know the time zone difference is where you are I am in Cairns North Queensland Australia.

If you have internet access to your laptop, download free/private version of Team Viewer and I can log into your ECU and see if I can find anything wrong.

However , to me something has failed, very rare for an ECU to die like that but not impossible.

Do you have a timing light, or have you physically checked for any form of spark output.

Can you post up the PCL file please.

Can you go to ECU CONTROLS tab 3rd from the left, go to the bottom tab TRIGGER SCOPE, crank engine and hit capture I think it says, been awhile since I have used it.

This will take a scope trace of your triggers and confirm if any type of signal at all.

Was your original crank sensor Mag Reluctor or Hall Effect.

If mag reluctor, is there any chance that the air gap had increased from a loose bracket etc.



Link to comment
Share on other sites

The original sensor was a hall effect. Running at 5v.

I have partially figured out what the problem is... It seems it has something to do with the settings. I have to change everything in the trigger section, store, and restart the ecu. And then set everything back to the original settings, then store. Then i can start the engine. But when i restart the ecu again, the trigger input is dead again.

Have you heard about this before?

I can upload the pcl file when i get home tonight.

Regards, Joachim

Link to comment
Share on other sites

That sounds very much like anti theft or ECU hold power is active.

These functions stop the engine by locking the triggers out.

By changing the trigger settings without a key cycle stops these functions working.

Link to comment
Share on other sites

Wow, i didn't expect that! I have been using the ecu hold power to run my engine bay relay. Funny thing is that i changed this relay at the gas station "thinking the heat was bugging with it" maybe enough to set it off then? It's located on AUX5...

And by the way, thank you so much Simon!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...