Jump to content

G4 plugin...Can not connect to laptop

Recommended Posts


I Have a customers car here. Its an r33 Skyline with a G4 plug in board in it. (About 2 year old i think)

The car was mapped about 6 months ago with no issues at all. I now have it back at the workshop for more upgrades but now I cant seem to connect my laptop to the ecu at all.

Im using the same lap top and the same version of Pclink I used previously...

As I plug in the USB lead im getting the usual noise from the laptop to tell me it has recognised the usb device but when I click on the connect icon I just get the no connection made message everytime.

I have tried pretty much every version of PC link thinking I had got the wrong one. Have tried 3 Laptops and a pile of leads...

I have 2 other Skylines in the yard with LINK and can connect no prob to all of them...

I then swapped the suspect ecu to one of the other skylines and still no joy. Wont connect

Im not getting the update firmware messages either... It cant connect to the ecu either...

It is password protected but Im not getting as far as that...Just wont connect.

The car is still running fine. No issues there.

If I try with earlier versions of PClink it tries to connect for about 30sec then says no but on the later versions instantly says NO...

I have probed the +ve pins going into the board, they are getting proper 12.5v

Has anyone seen this before??? Any one have any ideas???

Could there be a fault with the ecu??? if so can it be fixed???


Richard Bradley...:)

Link to comment
Share on other sites

Hi Richard,

When you have the ECU connected to your laptop and the ignition on, open Device manager and have a look under ports and see if your ECU is listed there. If it is not and you have all your connections correct, try another USB port to be sure.

If it is listed in device manager check the com port number it is on. you can then open PCLink, click options > connections and set the serial port number to match the one in device manager.

If the ECU still does not connect, right click on the ECU in Device manager, select properties > port settings > advanced > and change the com port number to a different one, preferably one with a number of 8 or less. Change the com port in PCLink to match the new one you have set in device manager.

If the ECU still can-not connect it is possible you have a hardware fault.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...