Jump to content

GTTLink G4X ECU not power up.


Recommended Posts

Hi all,

Recently we installed an GTTLinkG4X on a R34 GTT. however, with the ign switch on the ECU is not powered up. Checked the fuses all good and the ECCS relay also good.

Checked pin 4 it has 12V before and after the ignition switch is on. it doesn't pull to ground when the ignition switch is on. I try to ground pin 4 to ground with a separate wire and the ECU power up with led lights on on the ecu board.

I looked at the wiring diagram seems pin 4 directly goes to the ECCS relay with nothing in between. The pin 67 and 72 got only 1.72V when the ign switch is on. Pin 80 got 12V constantly. If I ground the pin 4 manually the ECCS relay clicks everything works fine. Any idea?

Link to comment
Share on other sites

The pin 31 was 0V. Found that the Ignition Relay didn't get any power. For testing wired Pin24 giving Pin31 12V and ECU powered up. However it doesn't work well as it interfered with the injector power supply. 

Tried to wire ACC power source to Pin31. ECU also powered up. However, it seems back feeding somewhere and the dash doesn't go off with the key off.

And now I have added a separate relay using constant 12V as the power source on 87, Pin 31 on 30, 85 with Pin 24, 86 to chassis gound... It doesn't work anymore. Pin31 has 12V but Pin 4 doesn't switch to ground.

I ground pin 4 the ECU is still switched on and can connect with the laptop. Not sure whether the ECU has fired up something.


Link to comment
Share on other sites

If 31 now has 12V but pin 4 is not at ground then that would suggest something is damaged I would say.  You can contact [email protected] if you want it inspected and repaired.  

Your other option since you already have a relay there is just use that to ground pin 4.  The ECU doesnt need the pin 31 input if some other device is controlling the ECCS relay.  So to clarify, the relay would be wired: relay pin 30 and 85 to Ground, relay pin 87 to ecu 4, relay pin 86 to ecu 24.  

Link to comment
Share on other sites

I tried using the relay to ground the pin 4. the ecu can power up. however, when i do the injector test, the ECCS relay keeps flicking and but not the injectors. this is kind of wierd as nothing on the wiring diagram from the injectors would gone through the ECCS relay... the situation is the same when i take power from pin 24 to pin31 to trigger the ECU at the first time. but now nothing is connected to pin31. only grounding the pin4 to chasis via a relay for trigger the ecu. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...