Jump to content

Serial link short circuit


Tkymik
 Share

Recommended Posts

I just bought a brand new serial link for my link g1 v4. I attached the serial link to the ecu and laptop then when I switched the ignition to power up the ecu so i can start downloading the current settings it shorted and burned the serial link. Did I do something wrong? or something wrong with the ECU? or is the serialink defective? I'm a bit frustrated because I think theres nothing wrong with the ecu because the car is running fine now. I need to tune it again after i install a turbo kit. Any ideas? Thanks

Link to comment
Share on other sites

Check the ribbon cable for any damage. Also check the ribbon conector on the ECU often pins can be bent / damaged. We will have to get the Serial link back to repair.

Link to comment
Share on other sites

Are there different versions of the serial link? A friend of mine checked my serial link and compared mine to another serial link which we downloaded from the net. He said they are not the same. Something about the positive and negative crossing causing the short circuit. Anyway to cut it short he already solved the problem for me. A trip to the local electronics store and bought a new IC, capacitors and diode then he built me a new serial link. Got it running last night with a usb to serial adapter and laptop(vista). I'm just a little sad because I bought that for $187(US).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...