Jump to content

Subaru V9 MAP sensor scaling


Jareds
 Share

Recommended Posts

Hi All.

Long story short, I have tuned and been driving my 2006 Subaru STI (ADM model) for a while now.  I have since found that out that the actual OEM MAP sensor being used is that from a 08+ Subaru STI.  I am however using the default Link Subaru V9 MAP sensor scaling. :(

To my knowledge the factory ECUS on the 2006 STI vs the 2008+ STI do definitely run a different scalings and offset in the OEM mapping.

Any idea how I can get the relevant scaling info on the 06 vs 08+ OEM map sensors, or can someone confirm the best thing to do here?

Definitely not looking forward to retuning the vehicle if the scaling has to change!  But my main concern is what has my peak boost been to date! ;)

Thanks,

Jared  

Link to comment
Share on other sites

 

Is the sensor set to the correct max kpa? does it read within 5kpa of the internal barometric sensor, if so all good as most sensors are linear.

Im relying on the default Subaru V9 scaling thats available in the G4+ unit - no idea what this curve / how the scaling is done.

I havent compared o the internal barometric sensor - however i did do a MAp sensor calibration once upon a time! ;)

The fact of the matter is that there is clearly a difference between the OEM 06 and the 08+ STI MAP sensors - Below are the Offsets and multipliers as stated in the OEM maps in terms of the MAP sensor calibrations:

06 STI - Offset (psia) = -8.005. Multiplier (psia/v) = 9.943

08+ STI - Offset (psia) = -5.666. Multiplier (psia/v) = 9.943

How this info relates to a linear curve I cant say. :) 

Link to comment
Share on other sites

The data that you quote for the 06STI sensor above matches the Link Cal "Subaru (V7-8)".

The data that you quote for the 08STI sensor above matches the Link Cal "Subaru (V9)".

I would expect since there is quite a big "offset" difference between these two that the MAP sensor calibration routine wouldnt have successfully completed if you chose the wrong sensor type.

Link to comment
Share on other sites

The data that you quote for the 06STI sensor above matches the Link Cal "Subaru (V7-8)".

The data that you quote for the 08STI sensor above matches the Link Cal "Subaru (V9)".

I would expect since there is quite a big "offset" difference between these two that the MAP sensor calibration routine wouldnt have successfully completed if you chose the wrong sensor type.

and THIS is the answer I was hoping for! ;)

THANKS ADAM! 

No retuning for me! haha.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...