Jump to content

Newbie Help


Recommended Posts

Hi - I'm trying to resolve a starting issue that has been going on for some time. Car cranks but wont fire. Its  been doing it for the last 2 years on a EVO 9. Various shops have replaced cam sensors, crank angle sensors but the issue seems to always return. I'm very new to this and decided to try and fix it myself (I'm the owner).  I have checked over the ignition and found there is no power to the ignition coils when its in a no start condition. - I have signal voltage from the ECU but no 12v on the connector pins to the coil packs so I'm guessing that's where the problem lies (everything has been replaced, battery and complete ignition system etc). Recently purchased a cable for the G4 ECU and hoping someone can steer me in the right direction on what I can check to possibly identify what the issue is ?

At this stage I have the PCLink software running and upgraded ECU to the latest firmware. When I connect to the ECU and try and start the car there are no fault codes listed, Ignition shows ON, CE light is on and ECU hold power is on. That's it. Switch ignition off and Ai3 Fuel Pump switches from off to on ? Although I have no exp that's seems unusual to me that the fuel pump shows off when trying to start the car but ON when I turn the ignition off ? Please can someone give me some steps to check ? I was thinking its an immobiliser issue but tried different settings to no avail.


Link to comment
Share on other sites

come on gentleman 19 views and I know all of those views are from people smarter than I. 

$200 - that's right $200 AUD to anyone that can make my car start. You name it and I will try it - if your right $200 to your bank account or BTC account you have my word.

What can I test ?

Link to comment
Share on other sites

You don't need to offer any money we will help as much as we can Free of Charge.

Your coils should be fed from a relay, when you say no 12v is this with the multimeter ground connected to the engine block or to a pin in the igniter ?

If your measuring between pins, then check to see if its is actually the 12v that is not there or the ground has been lost by grounding the black voltmeter probe on the engine block.

If the 12v is lost, trace the wire back to the relay, it may just be a dodgy connection or faulty relay or the relay trigger signal is lost.

In the meantime please post a copy of you pclr file and a log from when you try and start your engine.

Link to comment
Share on other sites

Hi Clint - the coils have 3 pins. I have a ground connection from ground pin to the neg terminal of battery (several ohms).  I have a 3.9v connection from signal pin to neg connection on battery (ecu signal ?) the last pin which should be 12v I read 0v when testing with a volt meter from power pin to neg connection on battery after pressing the fob door unlock which is also factory immobiliser (doors unlock fine).

It seems usual that everything I read suggests that signal voltages should be 5 volt yet I always get between 3-4.5 volt on every sensor/connection (crank sensor, both cam sensors, both ignition coils all read less than 5v on signal wires). not sure if this is related or not.

will post pclr file and logs tomorrow, its getting too late over here to attempt to fire her. damn neighbours..

Link to comment
Share on other sites

its a ADM Evo 9 which is similar to a JDM one so i think there is indeed a ignition relay (dont think the US versions had a ignition relay). I have attached a wiring diagram, wouldn't the immobilizer also cut power to the relay ? hence posting in the Link forums as I'm not sure I have disabled it correctly. will see if I can find the relay in the pic and test it. 



Link to comment
Share on other sites

 update - retested ignition and I do have 12v, must not have been picking up a good connection from the voltmeter. seems fine now but still no start. pulled the ignition out and the spark plugs don't smell of ethanol at all - is this a method of testing for fuel after trying to start car ? uploading some logs, not sure if I have done it right but if someone could cast there eyes over the files it would be appreciated.


Log 2018-03-1 5;11;29 pm.llg

Log 2018-03-1 5;18;00 pm.llg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...