Jump to content

ECU Connection Issues


BigBoiMR2
 Share

Recommended Posts

Hello,

I am running a Gen2 3SGTE in an AW11 with the ST205 PNP G4+ ECU.

I was able to setup the ecu and get it idling as well as tuned in the cruise area of my map.

I am now experiencing terrible connection issues that seem to be getting worse.

I have no issues when the engine is not running.

The ECU will connect to my PC initially and I can monitor at idle but recently if I try to change the fuel map the ECU will disconnect. The ECU will also consistently disconnect under light load while driving, this seems to be more frequent if I have PC logging running but will still happen within a minute or two without PC logging. once the ECU disconnects I can occasionally reconnect by pressing F3 but it will disconnect again quite quickly and then give me an error message about the com port. unplugging and replugging the USB will occasionally work but not for long. If I do manage to reconnect and try to download the log file from the ECU it will go through the download process but come up with an error message reading "Unable to save log file due to corrupt flash pages"

My laptop Is running windows 8.1 x32 bit, I have tried another laptop running Windows 7 X64 bit

Initially The ECU was on Firmware 5.6.4.3240 and I was using the new PCLink 5.6.6. I fully uninstalled it and the USB drivers, I then downloaded and installed 5.6.5.3338b along with the USB Drivers. I have tried to restore the ECU to factory settings and I have updated the firmware to 5.6.5.3389

I have read through the connection help file and checked off all the boxes, I have cleaned and checked all of the grounds, tried different USB settings and I am stumped at this point.

I have attached a log file that was running with the engine idling and then disconnected.

I have also attached my current map file.

I am probably overlooking something and I hope someone can point it out to me.

Thanks

 

ECU Disconnect.llg

Toyota MR2 MK1.5 Modelled Fuel.pclr

Link to comment
Share on other sites

I just reset the ECU to factory settings and made a new map on software 5.6.5.3338 and firmware 5.6.5.3389.

It seemed to correct the issue, I was able to connect with the engine running and start road tuning the map from scratch again. 

15 minutes or so later it disconnected and now it is constantly disconnecting again. 

Link to comment
Share on other sites

Hi Adam, I am using BKR7E spark plugs. 

I was using a usb 3.0 extension but I am also having the issue without any extension connected directly to the supplied USB cable.

The USB connector is the only non OEM connection to the ECU 

Thanks for trying to help me again!

15359471178688322377783946851195.jpg

Link to comment
Share on other sites

34 minutes ago, BigBoiMR2 said:

I was using a usb 3.0 extension but I am also having the issue without any extension connected directly to the supplied USB cable.

I have seen many times MR2 owners have connection issues when they use an extension cable to get into the cabin.  Can you do some more thorough testing without it, as in every case I've been involved with before, the extension cable was the problem.

Link to comment
Share on other sites

I couldn't wait for the morning, 

Just got back from testing with the laptop logging in the trunk. the ECU disconnected maybe once in the trunk and a couple times while I was holding the laptop so those could have been cord movement .

Watching my boost/afr gauge to stay in the cell ranges, then pulling over and using the mixture map to tune the fuel map worked great. 

bonus to this is no distraction in the cabin but the downsides are obvious.

Everything seems to be working well now.

 

Thanks again for your help.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...