Jump to content

350Z plugin. Very low power... SOLVED. 407 HP.


Recommended Posts


I just installed the ecu on a early 350Z with intake VVT only. Car is supercharged with no pressure (hose to intake is disconnected), 630 cc injectors. New coils and spark plugs gapped to 0,6mm. Power drops after 4500 rpm... See dyno chart. I used a ramp rate of 500 rpm/s. at the dyno. Afr is about 12.5-13. Both cams follows target. Log file shows steady timing. Knock disabled. I have checked with a timing light that timing is stable from low to high rpm when locked. I also scoped the coil #1 primary circuit with my 4ch Picoscope. There is about 2V power drop at the ground, but I adjusted dwell until coil was saturated as a quick fix. See scope trace. Anyone have any idea what might be the problem with the low hp? Am I missing something essential here? I dont want to apply boost before I feel the NA power is good enough... 


350Z 5000 rpm.png


350Z 2000 rpm - 5000 rpm.llg Obrestad 350Z.pclr

Link to comment
Share on other sites

The cams look a bit odd to me how they "top out" at about 30/33deg, even though you are commanding 40deg - like they have hit the mechanical stops.  The solenoid is commanding max 60%DC but it seems the cams cant move any further.  Did you do a cam angle test to confirm the offsets?    I thought the cams could move more like 60deg in these engines.

Also, it doesnt look like it is having any effect but the gear shift control is turned on, so I would turn that off.

The other thing I would try if it is a centrifugal supercharger is removing the belt.  With no restriction, it may be trying to pump a huge air mass and burning lots of power.

Link to comment
Share on other sites


I did a cam angle test, and it was about 2 degrees off. Yes one of the cams behave a little odd, but when I set max target at 30 degrees, they both seems to follow target. If I set at 40 degrees, one is not always following, it max at about 30 degrees. I set target to 50, and locked the dyno at 3000 rpm, it was almost 40 degrees. The other about 48degrees, which is max.Tried 60, but stopped at 48 degrees. One cam isnt always 100%, but it shouldnt have that low power?...

Turned gear shift off.

I just connected the hose and took some pulls to 4000 rpm. Seems like the problem moves closer to 4000 rpm now. Only 150 hp...

Car idles nice.

I think I will scope every coil to see if there is some that have some issues/bad connection. I only scoped #1.

Any more ideas?

Link to comment
Share on other sites

Finally sorted.

Scoped every coil, all good.

Hooked wideband to right bank, and it was pig rich... Injectors flow tested, all good.

Checked right hand side cat, and it was blocked... Checked left hand also, and it have started to getting blocked also... Cats removed and all good.

407 hp @ the hubs (Dynapack). Owner wouldnt rev past 6200 rpm, so I stopped there. Power was still climbing, but he had windowed a block before and wouldnt more.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...