Jump to content
Mustang

2002 Subaru WRX Stock MAP Sensor Data

Recommended Posts

European 2002 Subaru WRX with Link V7 - 9 plug n play ECU.
Stock Denso Map Sensor, Part Number 22627AA170.
I use MAP Sensor Calibration V7 - 8, calibrate the Sensor several times, BAP and MAP Sensor readings at ambient pressure are the same, around 101kpa.
Connect the Map Sensor to my  Vac / Handpressure pump and add pressure in 10kpa increments to the MAP Sensor.
Sensor reads up to 168kpa @ 3.3 V correct, above 168kpa pressure the Sensor won´t change it´s output, stays at 3.3V.
Can´t find any Data for this Map sensor, i think the MAP Sensor is faulty? 
Anyone with correct Data for this MAP Sensor?
Thank you
Marc


 

Share this post


Link to post
Share on other sites
11 hours ago, Mustang said:

Sensor reads up to 168kpa @ 3.3 V

Is that 168KPa Gauge pressure or absolute?  If it is gauge pressure then that would agree with the info in the PC Link help file:

 

Y0ZpJs1.png

Share this post


Link to post
Share on other sites

Adam,
Thanks for your answer.
Sorry, it is 168kpa absolut or 68kpa gauge pressure.
Strange thing is that up to 168kpa absolut the MAP Sensor, my Boost Gauge and the Link Gauge reading is the same / correct.
Found it out at the first test run with 200kpa absolut / 100kpa gauge boost and the Link gauges are reading only 168kpa absolut / 68kpa gauge.
200kpa absolut boost = 168kpa asolut MAP Link Gauge reding
To confirm the boost reading i have a calibrated Boost pressure Gauge installed.
installed a GM 3bar absolut MAP Sensor now, everthing is ok.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×