Jump to content

RPM 65535


Recommended Posts

Hi guys ,

i have strange problem on 2.0gm engine

we are running v88 on that engine for 10 years now, with bigger turbo every year or two, bigger cams and so on.

lately we have problem thar vipec reads 65535 rpm in LC.

engine is GM 2.0 I4, trigger 60-2, hall on crank and hall on cam

where we notice problem is on LC

LC is set to IGN cut, and what i notice is that while engine is cold it works fine, after engine gets hot, problems start.

I even try to change LC to FUEL cut instead IGN cut, and it seems better, it worked few times, but again at the end no luck, same problem.

What we tried so far


3x engine block --  0.00mm offset

3x crankshaft -- 0.00mm offset

change trigger wheel 6-7 times internal and external, tried with 60-2 and 36-1,

3x crank sensor (its hall sensor), brand new, and one from running car (same engine), also tried with VR

2 sets of coils,

2 sets of injectors

flywheel is 0.01mm off scale - 1/100 mm

mechanically everything seems perfectly fine.

i think im missing something here, give some advice please



here are few logs attached

edit: only thing we have different than past years, are really crazy big cams.



Log 10-09-19 6;59;20 pm.llg Log 10-09-19 6;59;52 pm.llg Log 10-09-19 7;02;01 pm.llg Log 10-09-19 7;02;25 pm.llg Log 10-09-19 7;24;35 pm.llg Log 10-09-19 7;24;49 pm.llg Log 10-09-19 7;25;43 pm.llg Log 10-09-19 7;42;53 pm.llg Log 10-09-19 8;35;34 pm.llg Log 10-09-19 8;54;36 pm.llg Log 10-09-19 8;56;49 pm.llg Log 10-09-19 9;10;35 pm.llg Log 10-09-19 9;13;42 pm.llg Log 10-09-19 9;16;57 pm.llg

Link to comment
Share on other sites

65535 is the largest number the ECU can calculate, so you have a trigger error that is causing the ECU to think the RPM is much higher than it is.  The best way to diagnose will be to attach an oscilloscope and capture what the waveform looks like coming from the crank/cam sensor.  

If it has a cam sensor you can quickly eliminate that as a possibility by just unplugging it after the engine has started.


You can see in the logs when RPM jumps, the dwell goes crazy and the error counter starts to increment quickly.


Link to comment
Share on other sites

 yes i know that max is 65535 and if ecu could show more than that it would show. 

thing is that trigger sensor is hall, and we change few of them, and we test with vr sensor also. 

we test and second and third trigger wheel, we also tested with 36-1 instead 60-2 

same thing. 


engine is running 100% methanol if that is important to say? 


as i wrote in first post, yes it have cam sensor and it is hall also.

we have this ecu for almost 10years and it worked perfectly, engine fires up on 100% methanol no problem so i dont think its crank to cam sync, BUT i will try to unplug cam. 


if i isolate problem i will let you know guys. 


but if you have any other suggestions please feel free to write 






Link to comment
Share on other sites

As something to consider it might not be the sensors them selves. The timing between them could be an issue (Sync happening very close to the gap on crank) 

Or it could be a coil / ignition issue where it is breaking down and radiating noise. (arcing out of coil / lead and not firing the plug) 

Link to comment
Share on other sites

i wrote reply and i cant see it now,

i will write again.

we did change 3 sets of coils, COP coils directly on plugs with amplifier, same problem

few sets of spark plugs gaped as usuall at 0.019" , same problem


tested with new engine 2 days ago, same thing. we take it apart, no signs of any damage on anything, main or rod bearings, crank, pistons, anything.

we also tried with another v88ecu, same problem.

we change mechanical fuel pump, same thing

honestly i dont know what to try and where to look.

"You can see in the logs when RPM jumps, the dwell goes crazy and the error counter starts to increment quickly. "

this is interesting, now question is, is this problem made by trigger error, or is trigger error made by crazy dwell time.

if it is made by dwell, my dwell table looks same as past 10 years.



Link to comment
Share on other sites

3 hours ago, josey said:

or is trigger error made by crazy dwell time.

No, the dwell scatter is a symptom of a trigger error.  It means the ECU isnt receiving the regular tooth pattern that it expects from the trigger.

As I said earlier, the quickest way to find your problem is to get an oscilloscope capture of the triggers - preferably when it is playing up.  The Oscilloscope will show us what is wrong with the waveform and this will usually give you some strong clues what is causing it.  Do not waste time changing random parts - there could be many hundreds of different scenarios.  Your logs show the ECU is not happy with the trigger so you need to start by diagnosing what it is about the trigger signal that the ECU it is not happy about.

Link to comment
Share on other sites

its 2 o clock in the morning, i just return from testing the car.

we didnt have oscilloscope but, some good news and some bad news.

tried to raise dwell, no luck.

unplug cam sensor, and engine works perfectly.

plug it back on, and it have trigger error.

unplug it and works perfectly.

we did that several times to be sure its cam sensor.


ok now bad news.

i couldnt find what was the problem.

check up wiring, its ok, change sensor, same thing.

we will take cams out to see is there problem with teeth on cam,

Adam what should i check before i get oscilloscope and check trigger problem?




few logs



caly 04 cam sensor off.llg caly 05 cam sensor on.llg caly 06 cam sensor on.llg caly 07 cam sensor on.llg caly 03 cam sensor off.llg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...