Jump to content

EVO 9 link g4x in boot mode?


Recommended Posts

Hey all, Im a recent link g4x owner and im just starting getting everything set up. I seen a new pclink update so i updated that and it required a firmware update. attempted to update the firmare and ecu ended up in boot mode. I dont understand why unless i have something wrong which i dont believe i do but its possible. Vehicle did have a fully charged jump box on the battery so i dont believe it was low voltage. i keep getting a something has caused and interuption in the update process message. 

Has anyone experienced this or have a simple fix so i may continue my setup process? any help is appreciated thanks.

Also just to note  i have contacted link tech support so if i find a cure for the issue i will post up. also great customer service from link so far!!

Link to comment
Share on other sites

On 4/25/2022 at 6:40 PM, Adamw said:

What ecu do you have?  Is the boot mode error shown any time you try to connect to PC link and wont let you connect?

Hey thanks for replying with interest in helping. I have a Link G4X plug and play model for the evo 9. I actually solved my issue. I’ll post up the info. Thanks. 

Link to comment
Share on other sites

Solved my issue! Here’s the info if anyone else runs into the same issue. 

With that said I still don’t know the direct cause of why I had this issue or what exactly fixed it. 

This is how it started,,,, About a month or so I downloaded my PCLink software and had it on mg computer. It wasn’t until a couple weeks or so that I got it connected to mg ecu and got my car started up on it. Literally the next day I noticed that the latest PCLink version was released on the link ecu website. Soo I downloaded the latest version and it requires a firmware update. I tried to do the firmware update and it failed. Ecu ended up in boot mode and I was stud with a brick. I attempted to reinstall the old version of PCLink and still in boot mode I could not get out. Reinstalled the new version and tried again with no luck… So moving forward.. 

I mentioned that I contacted link tech support and I want to say that those guys have been completely awesome with support. Very nice to deal with and they had a reply to my concerns within the hours. 

This info was not the fix for my issues but it may help someone in need and searching for a simple fix. . 

I was advised by link tech support that the easiest way to bring the ecu out of boot mode was to bench flash the ecu.  I’m pretty familiar with bench flashing so this was a simple process for me but for others who may not be familiar this process is exactly the way it sounds. It usually requires the removal of the ecu circuit board and hooking it up to power and ground on a bench or anything outside of its plugged in enclosure of the vehicle. Once the board is powered it usually can be flashed just as if it was in the vehicle. It just has absolutely no interference with anything other then the computer. I’ll post up some pictures of this process. 

Ultimately the bench flashing process did not directly work for me  I tried multiple times with different settings, USB ports, power sources and other attempts.

What did work for me was using a different computer with PCLink installed on it. Now this may be the difference but the older computer is using windows10 and my new computer is on windows11. Either way the older computer sent the firmware update through first try and the ecu is no longer in boot mode. Verified PCLink works now on both computers. 

Hope this information helps someone with similar issues. I would suggest that before the bench flashing process,,, try a different computer with maybe a different windows version before removing the ecu for bench flash….







Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...