Jump to content

GTRLink Start up issue


ae82ted
 Share

Recommended Posts

Hi all,

I'm having start up problem with two GTRLink G4X plugin ECU. The ECU dropped during cranking, with a little research it seems thats because of the current draw at the igntion switch during cranking.

A R33 GTS with GTRLink the voltage drops from 11.9 to 7V and ECU drops out of power. Engine crank but no start
Another R34 GTR with GTRLink the voltage drops from 11.9 to 6.8V and ECU drops out of line. Engine crank and not firing up

They both behave the same and battery drained quickly after a few tries.

I can see some fuel has been dumped to the cyclinders from the Lambda sensor but very very little. from 2.0 lambda to 1.3X lambda. No matter what Master fuel has set it doesnt change much. 

Both cars doesnt wire up a seperate relay for power supply to the fuel pump yet.

I've just finished tuning a R33 GTR with old G4+ with seperate fuel pump relay added. This car has no issue and engine starts great and easy. When i start working on the R33 GTS yesterday the car couldnt start and starter motor spinning slowly and slowly everytime i try cranking the engine. We jump wires to the car it just keeps cranking but still no start.

Today when i work on the R34 GTR it behaves exactly the same like the R33 GTS...

If thats the ECCS relay power supply issue( Design Flaw), besides adding a seperate relay to the fuel pump to reduce the current draw at ignition switch, what else can be done?

Thanks!

Link to comment
Share on other sites

It sounds like you may have a few problems - 1 is the ecu dropping out during cranking, 2 the R33 GTS sounds like the battery or wiring may be tired.  3, the R34  battery may be being drained due to a back feed.  

 

1. The most common problem in skylines is the ignition switch circuit rather than the ECCS relay side.   This is the wire that comes into pin 45 (or pin 8 on some R34's) that Im talking about.  

When the ECU receives voltage on pin 45 it feeds a small mosfet which grounds pin 16 to turn on the ECCS relay.  If the voltage on pin 45 drops below about 6V - even for a slit second then the eccs relay will drop out and ecu will power down.  The "battery voltage" that you see in PC Link is what is being received from the eccs relay so that doesnt tell you how low the voltage is on pin 45.  

The ignition switch circuit isnt a great design (R34 is improved a bit) and has quite a lot of high current devices connected to it, 20years ago when everything was a bit newer, less oxidataion etc it worked ok, but now I see this problem caused by the ign circuit quite often.  People often dont know they have a problem because the factory ECU wont drop out untill less than about 5V on pin45, but our ecu drops out at about 6-6.5V on pin 45.  

As you can see from the wiring diagram below, the single wire from the ign switch powers the fuel pump, fuel pump relay, fuel pump controller, an exhaust temp sensor, exhaust temp controller, 2 oxygen probe heaters and the idle valve...  And all of that current is going directly through the ign switch - there is no relay!  Of these the fuel pump is the biggest current hog, so often the easy fix is to move the fuel pump power to its own relay.  

JqBIJTV.png

 

3.  On the R34, the battery may be drained by the AC relay:

TiMHbUl.png

 

Link to comment
Share on other sites

Thanks Adam,

For R34 i have moved the AC Relay and requedt from AUX3 to Aux11, and from DI4 to DI9 because of the VCAM. Not sure the backfeeding is happening or not now.

 

Im charging up the battery and try adding a seperate relay to the fuel pump and see if it would cure the starting problem.

Link to comment
Share on other sites

2 hours ago, ae82ted said:

For R34 i have moved the AC Relay and requedt from AUX3 to Aux11,

The problem is not the aux, but the fact that the AC relay is connected directly to the battery so is live all the time.  If it is still powered like this it will still back feed.  It needs to be connected to an ignition switched source.  

ewZzDHn.png

Link to comment
Share on other sites

Thanks Adam,

Car fires up smoothly now. Besides adding the fuel pump relay...i guess the main issue is the trigger timing was way off from the base map to -95...

Anyway, i used a multimeter to measure the current draw when switching off the car it was about 1.2uA, unplugging the 10A fuse of AC relay it doesnt change at all. Can i assume this car has no back feed problem? 

I have another problem with the VCAM setup.. i will make a new topic for this. Thanks for your help.

Link to comment
Share on other sites

6 hours ago, ae82ted said:

Can i assume this car has no back feed problem? 

Sounds like it is ok.  If you do find a drained battery one morning then this is the first thing I would suspect.  

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...