Jump to content

Rb20det no spark and disconnect


Recommended Posts

Hi. I recently bought a Link G4 GTS/GTR plugin ecu for my R32 GTST Skyline. The engine is full stock apart of a T3 turbo, front GTR intecooler and FFP. The engine wiring loom is new from wiring specialities and the engine runs with the stock ecu. 
With Link ecu I follow all the instructions from the manual and when the engine cranks, the computer disconnects from the ecu, and the engine dont start, i think that its missing spark because i tried to start with ether and nothing happen. I’m using the base map that comes with the ecu and i config triggers and other parameters. Also i read some posts with similar problems, and i try to put pin 16 to ground and it stays connected because i can see the triggers and engine speed for a moment but when i try to start the ecu restart because the fuel pump sounds again and the rpm on tacho do the check as when i put on contact position. Other thing i tried is to put battery 12v to pin 45 as i saw on other posts, and doing this, the fuel pump doesnt sound and the rpm dont move. 
I try other maps downloades from this forum but nothing changes. 

Any ideas or suggestions?

Link to comment
Share on other sites

The LED going out suggests you still have a power supply issue somewhere.  I would temporarily ground pin 16 with a jumper wire and then check if the LED stays on while cranking then.  This will tell us whether the problem is on the ignition switch circuit or the ECCS circuit.  

Even though it is only dropping out for a very short time when battery voltage is lowest, we really need to get that solved first so the PC stays connected so we can do a log and see live data.  By the looks of your tacho during cranking I would say there is possibly a trigger setup issue but lets figure out the dropout first.  


Link to comment
Share on other sites

There is something not happy with your ECU.  There are errors and odd values showing everywhere.  There is potentially a hardware issue but lets rule out software first. 

I see it has quite old firmware so start by updating that.  One that is done, go to >ecu controls>restore to factory settings and preform that.  Then do a power cycle and re load your map in.  Then take a look at the runtimes screen to confirm if some of these weird errors are gone.    

For example on the ecu status tab of the runtimes screen below, there shouldn't be the hardware block 1 or 5v Analog supply error, The ECU temp should read about room temp, the Trig 1 Arming should show about 1.5V and the analog supply should show about 5V.  


Link to comment
Share on other sites

You need to turn off eccs sync if you have already completed the sync test, and your MAP sensor is reading wrong.  Your BAP is reading 97kpa while the MAP is showing 50Kpa, these should both show the same value when the engine isn't running. 



Link to comment
Share on other sites

  • 2 weeks later...

The log shows RPM and dwell so the ecu is commanding a spark.  Are you sure there is no spark?  How are you checking?  Do you get a spark if you use the ign test mode?  Do you have 12V at the coil when cranking?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...