Jump to content

Aem xseries wideband


Recommended Posts

Tried to set up my aem wideband via can today but can’t seem to get it to work.

have set it up as per the images after searching the forum but still no luck.

has the 120ohm terminating resistor installed in the dtm plug and wired in to can 1 on the ecu.

i get the green light on the aem unit to say it has power but nothing else.






Link to comment
Share on other sites

Is the gauge set to be Lambda ID 1, is it wired to CAN 1, plugin or wire in ECU?

Also if you go to the runtime View and across to the CAN tab do you see any errors showing up in the CAN 1 statuses?

Link to comment
Share on other sites

Hi Vaughan, I went to have a look at the connection at the ecu and can Lo had somehow snapped from the terminal in the jst plug! This is most likely the issue but cannot confirm until I get some new terminals delivered to test. 

But yes it was set to Lambda 1 and was wired to Can 1 in the nb2x plug in ecu. 

Once I have redone all the wiring I will see what happens in the runtime view if it still is not reading correctly


I appreciate the help 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...