Jump to content

FW update problems on windows 7


Recommended Posts

I saw this mentioned in another thread a while ago and wanted to put this there, but could not find it again. So here is a new one.


Since 4.9.1 (if i recall correctly) i have not ben able to update the fw with my W7 machine. Al that happends is the 'searching for ECU' message and it stops there. The wery first time i encountered this i fought it until i actually got to the point where you cycle the power. Thats where it stoped up again. I was afraid i had bricked the ECU as i had no chance of connecting to it again after that. That is until i dug up an old crappy XP machine i have laying around and installed PCLink on it. Then i was able to update everything as usual.

The update between that and the newest i did not dare to perform incase something simlar happend and i kinda hoped something would have been done to the problem by now.

Tried to update to 493 yesterday and its stil the same. Still have to use my old XP machine to update it.

I have simlar problems when i want to load a new map to the ECU. Going through some dark places before i have to break out the XP again.

For everything else W7 works fine for me.

Whats up whit this? Is there some kind of regional settings on my laptop that may be screwing stuff up for me? Im in Norway.

Link to comment
Share on other sites

Hi Steve,

Sorry to hear of your problems with the firmware updater and PCLink. We have PCLink and the firmware updater working here with windows 7, windows vista, and windows XP with no problems.

There is no regional setting that should influence if it works. 

If you have your ECU (with ign switch on) connected to your windows 7 machine and go to Device manager > Ports >  and you should see your ECU listed. Which com port is allocated to your ECU? The firmware updater only work with com ports 1 to 10. It is worth trying to change the com port and see if this resolves your problem. You can do this by right clicking on the ECU in device manager.

Do you have access to another windows 7 PC you can try?



Link to comment
Share on other sites

  • 10 months later...

Bringing this old thread up again (i`m the OP) as it now seems this bug have bricked my ecu for good.

Today i was to start the car up for the first time since october. Got snowy winters where i live.

But i figured i would build some oilpressure before start, so i disabled the injectors in the software and saved the change, then toggled the power. The thing when i run into theese problems is that my fuelpump is on the whole time my ignition is on. Not just priming for a few secs as it usually does. This happend at this point  but i was still able to connect. Then i tried to upgrade the FW but it failed at the end and im pretty sure it did cause it was in this 'faulty condition' (dont remember the fail message) Now it acts the same but im not able to connect with my laptop. ECU is on and i am able to see it in the device manager. From dev mangr it looks ok. Changing any settings here doesnt help. The fuelpump starts (and keeps going) when i turn on the IGN and my tacho needle does its dance as usual. I tried my crappy old XP machine this time too but that wont connect either. Tried to disconnect the battery for an hour but no luck. So now im stuck

To adress you latest questions: Tried different versions of PC link. Yes Its 64 bit W7. No there is no hold power function in use. And just saying: this is NOT a problem with my wiering. Car has run for years with it as it is.

Link to comment
Share on other sites

Hi Steve,

A couple more questions for you, so we can try and help track down what is happening.

What message are you getting now when you try and connect to the ECU in PCLink?

What happens when if you try and run the firmware update?

Which ECU model do you have?

Kind regards,


Link to comment
Share on other sites


I just shorted 2 wires and did 3 backflips while singing cumbaya in a high tone, and behold! Contact!

Well actually i decided to try me XP machine once more and the updater got contact with the ecu.

So now im golden again.

I did see some with issues like this on the vipec forum too so the problem seems to be 'real'

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...