Jump to content

Toyota 6 pin idle control


Recommended Posts

Hi   I have recently wired and set up a 1uz with the factory 6 pin idle control

Wiring the 6 pin stepper as per manual

Aux 5&6 to one set of coils with common 12v    and aux 7&8 to the coils 

I have got the engine running and set the idle base positions map to get a 800-900 rpm hot idle and have set up to run ecu hold power. And checked to make sure it all worked.

Whenever I switch off engine ecu hold.power activates and the stepper count drops to zero and pauses for approx 3-4 seconds then rises back to my set number for the temperature of coolant.


But when I go to start it again it's at 3000+ rpm but the step count is at the idle number     is this what happens when aux 5&6 are around the wrong way?

So when it resets the stepper it actually goes the wrong way and ends up thinking it's reset for idle again but it actually open all most fully?





Edited by BURGESS.DJ
Link to comment
Share on other sites

Yep this could be the direction is wrong or it could be that the max step count is incorrect and the stepper is loosing its position at the end of the travel.

You want it to reach fully open and then stop. It is not good if it sits rattling at the end of the travel. 

Link to comment
Share on other sites

Have tried this tonight   and no improvement changed wiring to another configuration listed on here for an i88 running the same 6 pin stepper on a supra after another user had the same problems

wiring is as follows    aux output to pin on stepper motor


AUX 5 to pin 4

Aux 6 to pin 6

Aux 7 to pin 1

Aux 8 to pin 3

I have confirmed wiring is correct with the larger number on idle base table lower revs

When I do the key off and the stepper resets the numbers of the Min and Max clamp values were 50 and 155 where the stepper was not clicking at the end of travel

but for the engine to engine to idle correctly the base value needs to be approx. 300 at 80-90C so the clamps need to be changed for this    from here I am confused as to why this wont work

as when I enter the number to  get the correct idle speed I want and then reset   the idle is crazy low 400-500rpms again each time   no matter what min and max clamp is set to


Link to comment
Share on other sites

The idle is 400-500 rpm   even after a reset  still 400 -500   needs to be at 300 ish for the idle to.come up to acceptable value


Does someone have a pinout with locations of where aux 5-8 go  for the toyota 6pin stepper  otherwise I will try a few different combinations from other ecus  but it seems they run with 4 wires only 

Link to comment
Share on other sites

Fixed      got that sorted and works good   now     another question 


I wanted to check timing  so I did the calibration as per the manual   

Locked at 10 and it was bang on o no adjustment required there but when I bought revs up to 3500rpm.and held it retarded to 5 degrees  I started to enter numbers in to delay and recheck  each time larger and larger start at 10 ended at 500 and no change   at all

The motor is a 1uz with twin distributor running stock coils and ignitors  is there a mechanical reason   there was no.change at all ?  

Link to comment
Share on other sites


Thanks for the reply  I figured it out.  I did a trigger scope and wave patterns are polarity correct   I then recalibrated the trigger  and entered a new value into ignition delay this time and pressed enter   and it worked.   haha. Didn't know I had to press enter while still in the screen. 

trigger scope 1uz ryan  at idle.jpg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...