Jump to content

Vi-pec i88 connecting to IQ3


Recommended Posts

I have a problem connecting my Vi-pec I88 with Racepak IQ 3 Dash.
When I read the v-net on racepak, it can´t find the information from the Vi-pec I88.
I get the error COD Type = 183 ID = 501520, Send Error. Template ID number expected.
I use racepak VNET cable SN 501520 Link G4 CAN-interface cable.

Now I have no iformation from VI-pec I88, I can´t set racepak IQ3 dash like, Oil temp / Rpm

I am a novice at this, and wonder what I should do for Vi-pec I88 to be found by racepak V-net.

I just switched from carburetors to Vi-pec I88 on my dragracing car.
I am very grateful for any information that may help me.


Link to comment
Share on other sites

That sounds very much like the Dash software is not talking to the V net module.

As you can do all the dash configuration with out the ECU connected.

We have a IQ3 here in house but unfortunately only have the Serial Vnet module not the can one so im not able to replicate you configuration.

Have you tried unplugging the dash for it power and then retrying to connect to the Vnet module?

Link to comment
Share on other sites

Thank you very much for your answer.

I get the information from racepak sensors in the screen
but not ECU sensor

I am novice at the  ECU, I have set the Can settings, as the information I got with the cable:  Generic Dash, CAN 1

I always get the same error when I use the cable SN 501520 Link G4 CAN interface cable.
(COD error Type = 183 ID = 501520, Send Error. Template ID number expected.)
It finds the cable but it always gets error code on it, it's a new cable.
When I not use it, it works to read VNET without error code.

But I want to see the RPM, oil pressure, boost pressure, water temp from ECU.
I have updated dash's firmware and I can have both racepak and ECU cable in. I do not lose contact with ecu.
I've tried to turn on and off the power on and take out the cable, but no contact with the ECU.
Is it the wrong cable, or is there any settings in the ECU, I have not done right.

Can I connect I88 directly to racepak IQ3 dash without linking it over racepak v-net?
If possible, what cables do I need and how do i connect it?

I have been in contact with the Swedish dealer, but they have no ideas what it could be.


Link to comment
Share on other sites

You will need the CAN ID and speed set in the ECU to match what the dash requires.

If the ID or speed are incorrect you will have no data.

You might find you need to have the USB connection removed from the ECU too.

The is no way to bypass the Vnet adapter.


Link to comment
Share on other sites

Thank you, i
try to do it.
The id is 1000 but I
do not know what the speed is,

or is it some way to find out what speed IQ3 Dash must have.
I try with different speeds and removed the USB connectionfrom from the ECU too.




Link to comment
Share on other sites

It´s kinda amazing folks having so much issues with Racepak dashes. I was about to purchase one and tried to ask some details from manufacturer directly and from Racepak forum. No one bothered to answer and I didn´t purchase one. Happy with that decision.  

Link to comment
Share on other sites

My IQ3 Logger dash works great.  Below are the settings I was advised to use by Racepak.  They don't monitor their forum much, but the tech dept. got back to the company I bought the dash from with-in 30 min and I had my answers.

Can 1
Data Rata 1MBPS
CAN ID 1000
Data Direction ECU Transmit
Transmit Rate 20 or 50 is avail.

Edited by Cnstman
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...