Jump to content

unstable rpm, weird laptop connection issue


Recommended Posts

hi everyone

storm g4+ Suzuki m16a engine

Has anyone had a issue like this before?

Can not at all get a stable rpm or idle to adjust my ignition and fuel tables, set base timing to 10deg and idles perfect as is locked, hit enter, then revs bounces up and down like its hunting, look at my ignition table set the cells the crosshair is going to and from to 10 and still doesn't change. so thinking its not a timing issue?

Playing around with my fuel table doesn't help at all. I cant even use autotune as cant hold rpm in a certain cell.

Then I unplugged pc cable and idle increased dramatically and slowed down the hunting a bit but still un tuneable. I have no idle control valve. so slow idle down and is a bit smoother again but still not good enough at all. I'm not sure if this is a ecu, laptop or engine fault, thinking its not a engine fault such as a air leak because when I set base timing it idles perfect. Have been sent a tune from another m16a engine just to get me started.

So anyone experienced this or any ideas to help me out? can post up a video what's happening if I can post videos on here, but I think iv explained it good enough  :D


Edited by r32skizzzaaa
Link to comment
Share on other sites

ok I think I have messed this logging up, let me know if I need to redo it, played around with configuration started engine and idled perfect, then started to slowly pack up, then died, realised 5v spare wire had earthout out took me a while to find lol. but after that everything went weird, running like it used to and worse, so here are some more logs, from what im reading from it I can see when it was running good then readings went out the window so im guessing that's when my 5v was earthed. I think you would like me to re log, so I can I just had enough with it tonight. starting to understand the logging side so will get a good log sometime.


wont let me upload them <_<

Link to comment
Share on other sites

I did find my fpr and map hose was taken off same point on engine, changed to individual points and engine now running a lot better but still not 100% but using the q and a keys to change fuel cells I still can not reach my afr target, my lambda 1 reading does not change much at all to anything. but looking back in the logging I can see it does change from 10 to 7 but nowhere in between?

ECU Log 2016-02-9 7;02;49 pm.llg

ECU Log 2016-02-9 8;37;50 pm.llg

Link to comment
Share on other sites

Thanks for the ECU logs. I can see how your idle is not too smooth and that your Lambda reading is very rich. Can you attach your base-map (File > Save As..).

Are you running petrol as your fuel? What type of lambda sensor are you using? Is it coming in over CAN or An Volt channel?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...