Jump to content

Fuel pressure sensors


MagicMike
 Share

Recommended Posts

So I have had a shit of a time trying to get fuel pressure into the G4+, and I am pretty sure if is the sensors, but just throwing this out there...

I had 1 sensor, off a Defi multi gauge (was working, showing correct pressure on gauge). I removed the gauge and kept the sensor installed, and ran new wires to the link. Found a calibration table, set it up etc. Now the issue I have is that the voltage on the signal wire is not changing. It's about 1.8V.. At this point, I assumed that the defi gauge must do something inside its brains, so I shelved it.

Bought 2 new 0.5 - 4.5V sensors off ebay. Having the same issue in the signal not changing with pressure. Funnily enough, both sensors give different free air voltages, which don't change with pressure applied. One is ~0.8V and the other is ~1.4V.

Hard to believe that 2 cheap chinese sensors from the same manufacturer (and probably batch) are so different, yet still behaving the same as a third unrelated sensor.

I have tried different ECU inputs (both on the expansion loom and reclaimed the OEM MAF input). Even tried both sensors in different rail reference locations (have a gauge installed also so I know there is pressure).

 

Events above not in true chronological order.

Have an auto elec mate coming on the weekend with a known working sensor (working with G4+) and we will have another go. Just wondering if anyone else has happened on this type of thing, or have any obvious (or not so obvious) things to check.

Confirmed (own) 5V supply, (own) sensor ground. Voltage the ecu sees is the same that the sensor puts out.

Edited by MagicMike
Link to comment
Share on other sites

As a reality check I would try it independent of the ECU - what I mean by that is still use the 5V from ecu but just connect the signal wire to a multimeter or something instead or the ECU.  That will eliminate any effects of analog fault settings etc adding confusion.

I have a couple of those cheap Chinese sensors on my dyno for odd testing jobs that work ok but I have a vague recollection of having some drama with them when first hooking them up.  I think from memory the pinout or wiring colours did not match the document that was supplied (that was quite a few years ago though).

Also be aware you can get those sensors in 12V and 5V versions so there could be something amiss there too.

Link to comment
Share on other sites

Yeah thanks mate, I have tried as you suggested, not feeding the ecu I mean. I have also noticed that the pinouts are different between the defi and the chinese sensors, so I have tried all possible combinations. I also tried feeding one of them 12V.

 

Buy shit buy it thrice I guess!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...