Jump to content

STOP command via CAN


Grant Baker
 Share

Recommended Posts

Hi

Using a PDM (MoTeC) over CAN to a Fury, the Keypad has the engine "Stop" button on it.

I've enabled a "receive" Stop Signal can message, but it's not "stopping" the engine when pressed. It is being received correctly, so what is set incorrectly?

image.thumb.png.f3d77da201fff49d52aaa7c01b07761c.png

Link to comment
Share on other sites

Although there is a problem with your CAN set up also, I just tested this on the bench and there does seem to be a problem with the "Stop" parameter being received over CAN.  It doesnt work for me either.  Swap it to "CAN Anti-theft request" and it will work as intended.  Under the Chassis & Body menu you will set the anti-theft as below.

Now the problem with you CAN setup in the screenshot is you have the parameter in Byte 0 but you also have the frame ID set for byte 0 - that is why your Byte 0 is showing up red, it should be grey if it is happy.  Set the ID position to "none" should fix that.

7E7HbFZ.png

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...