Jump to content

Misfire Headache


Recommended Posts

Hi Guys

Ive got a problem with my car.

It is a Toyota Celica Gt4 rally car with the Gen 4 3SGTE, it has had a freshly rebuilt motor and a brand new "milspec" wiring loom with all new sensors and electronics. ECU is a link Fury.

we first put it on the dyno and has a misfire at exactly 4800rpm under full boost (19psi wastegate). we narrowed down the problem to cylinder 2. 

we have swapped around multiple set of coils, spark plugs, injectors and the problem persists on cyl 2. the compression is perfectly uniform across all cylinders.I also removed the valve springs and they were fine. i also ran separate wires for the injector and coil, directly to the ecu bypassing the loom. we also tried another ecu and updated the firmware.

I then put a different wastegate spring (10psi) in and the missfire is still there, however not as aggressive.

The misfire occasionally goes away but is there 90% of the time

I hope you guys may have some ideas on what could be wrong (im now out of my paygrade)



Link to comment
Share on other sites

it has the factory caldina coil on plugs with built in igniters. at one point i borrowed some brand new high output coils- with the same result.

my tuner checked the trigger scope while on the dyno and seemed happy enough (its completely possible he missed something of course)

I have attached a log and the tune file

Log 2018-07-5 6;08;55 pm.llg

rally car.pclr

Link to comment
Share on other sites

You log shows 3 areas where the RPM limiter has been reduced to 4000RPM due to the diff fuel pressure.  Can you try temporarily adjusting that 4000RPM row to the same as the rest of the table and see if that is the problem.






Edit:  Actually after a closer look, the rev limit thing above doesnt appear to be all of your problem, I see the Lambda go wonky at 4800 with no limiter applied suggesting there is a misfire there.  The other thing I would do is reduce dwell time, those coils dont like too much, they overheat with more than about 2.1ms dwell in my experience.  Try something like below



Still would like to see a triggerscope too please - just at idle will be a start.


Link to comment
Share on other sites

That has sorted it

dont fully understand it but it works!

I actually had it wired correctly at first, then when it first started, the tuner swapped the polarity as he thought it was wrong. a learning day for all!

Thanks very much for your help and quick response.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...