Jump to content
Joseph Yong

Altezza Trust turbo fuel gauge not respon

Recommended Posts

Hi Scott & Simon,

Refer to the above mention, I have received ECU send back by Link and install back to the car everything work fine, only the fuel gauge is still not working correctly, it only drop quarterly. as mention above, in order to make the Altezza fuel gauge work correctly, we need to change the fuel equation mode to moderate. I have send my car to my tuner, we tested once we switch to moderate mode we can't start the car, like no fuel supply to the engine. My tuner ask me to check with link and request for a based map with moderate fuel equation mode setting.

My current Spec as below

Stock Engine 3SGE G1 with Greddy Trust Turbo Kit

Warbo Fuel Pump

Work Stage 1 Fuel regulator set at 4 psi

Sard 530cc Injector dead time 1.10 m sec parts no 63516

changed stock O2 Sensor to Bosch wide band sensor with Depo controller

Sard 68c thermostat

 

Can I have your Email Address so I can send your my current based map and some of my log file.

Many Thanks.

 

Joseph Yong

Email josephyong@live.com

Share this post


Link to post
Share on other sites

That actual testing is not to bad it will either work or it won't.

The hard part is the tune will need to be changed over to modeled mode which will require the car to be put on the dyno and a tuner do the retune.

It needs to be in modeled mode to give an instantaneous fuel consumption reading which is apparently required for the fuel gauge.

Hi Joseph,

The ECU will need to be re-tuned in the modelled fuel equation, if the tuner is running into problems with this we are happy to help. A base-map and PCLog can be sent to tech@linkecu.com along with a description of the problem.

Scott. 

Share this post


Link to post
Share on other sites

What was the altezza fuel gauge issue ? I have a jzx110 pretty much same tank set up and all.  Have a kurofune on hks harness and seems the gauge gets to 1/4 tank and won't read any lower does the car need to see injectors ect for Messure the last bit in these cars. ? 

Share this post


Link to post
Share on other sites

The Altezza uses a "BEAN" network to communicate between the various electronic modules in the car.  Our plugin Altezza ECU has a BEAN comms module on board.  I believe the problem with our original revision that gave the odd "1/4" fuel level increments was some data missing from the BEAN messages.  Something like "instantaneous fuel consumption".  If your car uses the same system then you may find other dash instruments and things like alternator light no longer work.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×