Jump to content

Setting up ECU Master CAN to LAMBDA on Link G4+


Recommended Posts


I need help I have wired in a ECU Master CAN to LAMBDA into the ECU but I am struggling to get the find it on the Link G4+ software, I have tried all the CAN ID's I could find on the internet but still no luck. I am selecting the wrong information please see attached screen shot 

Link G4+ 2.png

Link G4+.png

Link to comment
Share on other sites

Ok, that looks good, we should have slightly higher than 2.5V on CAN H and slightly lower than 2.5V on CAN L when there is data so this at least confirms CAN wires are connected to the ECU correctly and data is reaching that plug.  

Do you have any voltage coming out of the ECU Master analog output pins?  This would at least confirm the device is powered up and working.

Link to comment
Share on other sites

So all looks correct to me.  And looking at your log again Im pretty sure the ecu is communicating with the device fine.  There are no CAN errors and It is reporting "Lambda 1" where as it would be 0 if there was no data.  

How long did you run the engine for when testing?  Maybe they have a start up delay?

Try the attached map, I have set up an extra CAN channel to receive battery voltage reported from the lambda, so this will confirm there is communication.  If CAN AN Volt 1 shows data then it is working.  


Bruce MAP29_10.2021 with CAN lambda test2.pclr

Link to comment
Share on other sites

Ok, that log shows there is communication from the CAN lambda and the ecu is receiving the data correctly.  It is just not working.  There are no CAN errors, It is reporting Lambda = 0 and temperature = 0 the whole time.  Battery voltage at the lambda (CAN AN V1) is being reported correctly as ~14.1V.  

So Im suspicious this thing is a dud.  Attached is a new map, do us a short log with this one.  I have added a couple more channels which will capture the error statuses and calibration state but not sure how much that will help - they give limited info.  




Bruce MAP29_10.2021 with CAN lambda test3.pclr

Link to comment
Share on other sites

The errors being reported but the Lambda are:

  1. vub low voltage.
  2. Heater open load

Everything else looks ok, it reports calibration has finished and device version is LSU 4.9.  I would assume that means the sensor is dead but you will need to confirm that with them.  

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...