Jump to content



Recommended Posts

I had similar problem with my newer laptop. The ECU is not getting detected when connected directly to USB port --- but is working whenever the ECU is connected to a USB hub instead.

USB-C to USB-A or USB-A to USB-A hub both works for me.

Link to comment
Share on other sites

I just had this issue. Tuned a car with my laptop all day, went home to my own with the same laptop and it wouldn't connect. Found the Link in my device manager as a USB device, not a COM port. disabled the USB port and it worked again. Took a few tries. I tried a USB hub like above and it didn't work though.

Also, holy RAM size OP.

Link to comment
Share on other sites

I have seen this happen on some modern laptops with USB-C ports.  What I think is happening is they have the USB port set up to operate in client mode by default.  It must need to see load on the power pins for the port to be switched to host mode.  Since our ECU's are powered by the car battery they dont use the USB power pins at all so the laptop cant detect a client has been connected.  This is why if you plug in a USB hub (that takes a little power) the port is put in host mode and the ecu is detected ok.  


9 hours ago, curly said:

Found the Link in my device manager as a USB device, not a COM port.

G4X should have entries in both categories, you can swap between serial comms mode (possibly less noise sensitive )and direct USB mode (a little faster) in the communication settings.  

Link to comment
Share on other sites

9 hours ago, kazuyaito2002 said:

Then, will it be possible to connect HUB to USB-C and communicate? Will programs that improve it be updated in the future?

It should also be possible for you to make it work using a USB-C to USB-A hub.

I don't think software updates would be able to make it work (without a hub) in the future as the switching of the USB mode (client or host) is controlled by the BIOS --- that would be under the scope of the laptop manufacturer.

Link to comment
Share on other sites

No, shouldnt be anything else required.  Check that connection mode and port are both set to auto is usually the most foolproof. 

Im assuming the ECU is powered up?



In windows device manager, do you have Link Engine Management in both Ports and USB section?


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...