Jump to content

Need help with 1UZ VVTI


Recommended Posts

Hey Link,
I have 1UZ VVTI and Link G4X XtremeX.
There are several problems.
How to connect the VVTI solenoid correctly?
Where to connect phase control sensors?
I did not find a sample map for 1uz vvti. 
If anyone has it I would be happy if you can share it.

Thank you.

Link to comment
Share on other sites

Wiring info is in the help file.  Use the contents tab to navigate to the following page: 

Wiring Information > Output Wiring > Variable Valve Timing (VVT) Solenoids > Specific VVT Applications > Toyota 2UZFE VVT Wiring

We used to have a 1UZ vvt dyno engine, I found the map below attached below that may be a starting point.  It is from a very early G4X prototype so I dont know how good it is but give it a try.  

RAT 4 Base Map for G4X 6.7.11.pclx

Link to comment
Share on other sites

Thanks a lot!

But my engine won't fire up.

Look, please my logfile and map file.

(clarification, I do not use the map sensor and E-throttle because I have a multi-throttle intake)

tests of injectors and coils passed successfully.
fuel pressure 4 atm.

PC Datalog - 2022-12-5 9;53;55 pm.llgx


Link to comment
Share on other sites

Do you not get this message everytime you connect to the ECU?


It will not run an engine until it has been unlocked.  


You will also need to set up your fuel table with throttle position on the Y axis, MGP is not going to work when you dont have a MAP sensor.  

Link to comment
Share on other sites

When I saw this message, the ecu did not show engine speed. 

now the ecu is activated

I figured out why the engine wouldn't start. The signal and ground wires on the crankshaft position sensor were mixed up.

changed the wires and the engine fire up.

I also changed the map to download via tps

But I have new problem :(

only the right side of the engine works (2,4,6,8 cylinders)

the left side (1,3,5,7 cylinders) do not work.
I've checked everything I can, but I don't understand what's going on.

there is a spark. I checked the basic ignition timing using a strobe light. everything works correctly.

I tried turning off the phase sensor. I tried swapping the wires on the phase sensor.

the signal goes to the injectors. there is fuel in the rail.

below you can see the logs and scope trigger.

Аny help would be helpful. Thanks!

1uzvvti_e30 tps load.pclx


PC Datalog - 2022-12-11 9;52;09 pm.llgx TriggerScopeLog11.llgx

Link to comment
Share on other sites

Is the engine known to be good?  Has it been apart recently?  The ecu setup and trigger look ok.  The MAP signal is really noisy and you have very little manifold vacuum, this may suggest either some intake valves are not closing or the cam timing is out. 

I dont see any other obvious clues.  


Link to comment
Share on other sites

@Brad Burnett yes, ITBs from suzuki hayabusa. two pieces)

@Adamw yes. I think right, because the right and left cylinder heads showed the same when I used the pressure gauge. but I will check again.

I also noticed that there were wet spark plugs in the left head. I changed them. did a start and unscrewed a new spark. she was wet again.

Link to comment
Share on other sites

ITB balance issues are the most common issues i see with starting and idling issues, Most people never touch them.

I also run an ITB 1st gen 1uz. 

Buy a couple sets of these:


Just make sure that all the balance tubes are disconnected so the throttles arent pulling from other cylinders.

Link to comment
Share on other sites

  • 4 weeks later...

@pikonshin, I don't mean to hijack your thread, but I am also running some Hayabusa ITB's on a project I'm doing and I was wondering if you are using the injectors from the Hayabusa as well, and if so, what generation.  I've been having trouble finding the specs for the injectors.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...