Jump to content

CAN Bus randomly stopped working


Recommended Posts

Hi all,

My question seems somewhat basic compared to some of the other things I have read but it is still kicking my a** so I need help. I have a G4+ PnP in my Evo 8. It is running the Link CAN Lambda module and I am also running a PLEX SDM-300 screen. Ever since I had the car tuned, I have had dramas with it missing and stuff and we've logged data and found little bits and pieces but now we are seeing random spikes in the RPM between 10,000 & 20,000 which is causing it cut ignition and pull timing etc. Trying to be thorough I decided to check my Cam and Crank sensors, I pulled the connectors apart, cleaned them, made sure the wiring was ok etc. 

After reconnecting the sensors, I put the key back in the car and fired it up but no data was streaming to my PLEX dash although it was powering on and I was getting nothing registering from my lambda sensor. I took the car around the block just to make sure everything else was still working and it is, all my other sensors are working.

I went into CAN settings in PC-link and noticed that both channels were turned off, I turned them back on and then went to scan for the devices but it keeps telling nothing can be found

I have tried the following steps to resolve it

1. Reload the most current tune

2. Reload the previous tune file

3. Reload firmware

4. Revert to default tune as supplied with the ECU and reload current tune

5. Pull out wiring and confirm everything is still plugged in

Nothing has worked so far, the fact it is powering the dash is what confuses me, obviously there is power being transmitted but just no data.

Pretty open to suggestions at this point


Link to comment
Share on other sites

I spoke to the guy that installed/tuned it and he said everything is running off CAN 2. So I have uploaded shots of the CAN status screen and then of what the ECU was showing for Lambda 1, even though the car was off when I took the Lambda 1 screenshot, that is what it was showing when the car was idling. So this would rule the ECU out as being the issue I am assuming?

CAN Status.jpg

ECU Status.jpg

Link to comment
Share on other sites

Sorry I think I just have mistyped it, they are the readings I was getting with the car running. Nothing changed in terms of the Lambda status and CAN status when I shut it off again which is why I used those screen shots, my neighbours weren't super excited about me having the car going that early in the morning so I couldn't leave it running.

Link to comment
Share on other sites

Can you attach your map also.  I cant think of anything that would cause the CAN settings to turn off by themselves so something doesnt sound right there.

If you can give me a copy of the last known working map and also the current "not working" map would be helpful.

Link to comment
Share on other sites

So in the end I ended up pulling my ECU out after checking everything else and switching the connector from CAN 2 to CAN 1, set it in the ECU to mirror what was on CAN 2 and it started working perfectly. It appears like CAN 2 is essentially dead? My tuner logged in remotely and checked out some ECU stats and we saw weird things like a max recorded RPM of over 40,000, coolant and oil temps of 7000 degrees etc.

We have reset everything and will see what happens. I will upload the most recent tune, everything is still on CAN 2 here though because I forgot to save it with CAN 1. I plan on also taking the car for a drive later to see if my original issue of random RPM cuts still occur and will be logging that. Will upload logs later too.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...