Jump to content

PCLink Software Issues


Recommended Posts


I'm having a problem with the PCLink software. When I change the layout - or even switch from fuel to ignition maps, the tables / graphical views fail to refresh properly, leaving images of whatever was there before in place. It works when I first load the view, but if I change anything it fails.

I've searched for forum and I can't find any resolution to this (I've seen that there was another thread where people were experiencing slowdown).

I'm using a brand new Lenovo laptop bought specifically for the purpose of mapping a car - this is the only software running on the machine.

It's Windows 10 and the latest version (2017?!) of the PCLink software I can find. 

The PCLink Version Information says the following:
Build Date: 09:44:11 Feb 15 2017
DLL Version: 3372
Build Date: 15:09:01 May 16 2017
OpenGL Version: 4.5.0 - Build
Renderer: Intel(R) HD Graphics 610
Vendor: Intel

I've attached a screenshot of the issue... the right hand corner window is completely inoperable. I've reinstalled the software with no benefit.

Any help greatly appreciated - I need this to work in Jan to get the car mapped and ready for the race season.




Link to comment
Share on other sites

Hi Richard,

I'd tried that before, but had "this software is not verified by your manufacturer", or something to that effect.

However, your response prompted me to try again and force it on, old skool. 

The PCLink Software appears to be responding better now - so fingers crossed it was the driver. Seems odd for a brand new machine, but so long as it works for now. I'll keep playing and see what happens.

Thanks for the tip.




Link to comment
Share on other sites

  • 3 months later...

good day everyone.

i too am having the same issue. i upgraded to 5.6.6 and it didn't go away. i'm also using the integrated graphics card on my windows 10 laptop. it does work better (but not completely solved) when i put the scaling to 100% but it way to small to view on my 14 inch laptop.

any suggestions?

Edited by evo_gerard
Link to comment
Share on other sites

Hi Gerard,

Changing scaling didn’t work for me. I installed the latest Intel graphics driver (it said it wasn’t supported (yet) for my laptop, so it was a bit of a pain to get on there - but it should be mainstream now).

Since doing this it’s been fine.



Link to comment
Share on other sites

Hi Senordos,

i fiddled a bit more and tried the windows 10 compatibility tester. its initial recommendations didn't really help so the tester probed some more. the second recommendations looked to help alot. i haven't tested it connected to a car but the ghosting of the previous tables are gone


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...