Jump to content

PnP Subaru V9 DI malfunction


Recommended Posts

I have problem with AC request (set on DI 3) of Subaru PnP board. When pushed On it works normally but when you push to OFF it wont get OFF. Using extension cable I changed AC request to DI7 but has same problem. In the next day I test again, first time push ON and OFF was okay after that it failed all the time.

I tried to replace Subaru HVAC controller still get same problem

Just curious to try use AN 6 as AC request and set AC clutch output as GP output, it works but not as good as factory setting

Please help


Link to comment
Share on other sites

I add diode . With engine idle AC switch off the voltage 0.8V not stable but slowly up. In about 2 minutes it become 1.2V but AC still inactive. I switched AC on voltage goes to 1.3V, AC active. When AC switched off voltage remain 1.3V

AC won't get off

Link to comment
Share on other sites

The change in voltage level between on and off is not what would be expected. 

The voltages you mentioned when it worked are more what we would expect. 12Vish to 0ish

It could be there is an issue with the gas levels or the pressure switch. But it is an issue outside of ECU settings. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...