Jump to content

2JZ-GTE not firing.


JesterTiger
 Share

Recommended Posts

This is prob another one for the Legend AdamW. 
Mk4 Supra 2JZ-GTE, was running, owner stopped at a petrol station to take some pics, then the car wouldn't run again.
the wiring harness on the right arch was rubbed through, quite a few needed splicing. everything's matched up as it was. 
however it wont fire up. Gone through all the basics, Checked Timing, couldn't get a spark at first. now I'm getting a sporadic spark. had to use a new 2 core shielded cable to get the crank sensor working, i think the original one was battered a bit. still not seeing 100% RPM signal in the ECU. need to rule out anything to do with the ECU. so i have the tune and log file of the engine trying to start. it cranks over great, just suddenly try's to fire and then flames out the inlet or backfires like a cannon going off. checked for power at the coils, power at the injectors. which is has both. 
has a Fault of Code 11:  AN V1 GND fault. Think thats the MAP sensor error. but cant see why that would stop it running, if at least for a few secs. 
could it still be a ground fault? like a really bad earth somewhere? i did do some tests and i had ground at the ECU and engine. 

supra fault.pclr supra no start fault.llg

Link to comment
Share on other sites

7 hours ago, JesterTiger said:

has a Fault of Code 11:  AN V1 GND fault. Think thats the MAP sensor error.

MAP sensor looks ok, this is possibly just an historic fault code.  Have you cleared the codes?

 

It looks like it isnt happy with something about the trigger, can you do a triggerscope while cranking and attach it here.  You can unplug coils or fuel pump relay if you dont want a bang when cranking.

 

Link to comment
Share on other sites

Sorry its taken a few days to reply Adam. Been hit by the dreaded bug thats going around. 

Got a trigger log and pic. I have to drop the voltage right down to see anything. 

Both sensors are tested and are well within parameters.  The wiring checks out, even bypassed it where it was damaged. 

Could the damage have caused a failure within the Link ECU itself? 

supra 2jz-gte crank trig.jpg

Trigger Scope Log 2022-10-3 3;45;22 pm.llg

Link to comment
Share on other sites

1 hour ago, Adamw said:

That trigger scope shows no signal at all.  Are you sure you only clicked the capture button while cranking? - Not before cranking?

that explains a lot..  whilst cranking. . ok will do it again in the morning. 
 

Link to comment
Share on other sites

Went back and redid the trigger scope. 

Same results. 

Now i have been through and tested the sensors again. Ohms are all within spec. Tested the wiring. Thats all good. Bypassed the crank wiring with a new 2 core shielded cable. Same results. 

The ecu sees trig 1 and trig 2 and they go green. Every now and then it sees a rpm signal, sometimes its 36 then 3000 ish. But its never a complete constant signal. 

Tried disconnecting the cam triggers in case the wiring was crossed somewhere and it was causing things to go screwed. Ecu now as expected only sees trig1. But the voltages are tiny. Min 0.33v and max is less. 

Im going to run a test using a 3SGE dizzy with the VR sensors on that. Spin it over on a drill and see if the ecu can pick the info from that ok. (Got several of them around from the MR2s). 

But this whole missing trigger thing is really screwing with me. Everything is there and should work. Tests are fine. Wiring good. Just the Link doesnt see what i expect it to see. 

3 trigger scopes attached. Last one is with only trig1 wired in. Yet its still seeing negative pulses in trig2  

Trigger Scope Log 2022-10-5 12;39;14 pm.llg Trigger Scope Log 2022-10-5 11;26;45 am.llg Trigger Scope Log 2022-10-5 11;16;56 am.llg

Link to comment
Share on other sites

Did a test with the 3SGE VR pickup and im getting a pulse through the trigger scope. 

So pickup fine. Wiring fine. Ecu fine. 

 

And then it hit me. Reluctor wheel on the back of the crank lower pulley. 

IT HAD COME OFF!!. 

Engine was only built 1200miles ago. So bit un nerving. But will get on that tomorrow.  

 

Link to comment
Share on other sites

On 10/12/2022 at 4:55 PM, koracing said:

I've had to weld that wheel on the OEM 2jzgte pulley several times.  The scopes you have definitely look like no crank trigger signal.  Did you get this fixed?

Its all in bits now waiting for parts to turn up. Customer has opted to replace the entire timing belt set with nice fresh purple ones. and a TiG welded lower pulley. 
it was the hunting around bit that got me. i went in because it had the Right wheel go through the loom, that happened at the same time it stopped running. so it was all directed at that being the issue. going down checking all the wiring, checking for no trigger pulse, thinking its still a wiring fault and maybe its the ECU that got spiked. only when i went in and pulled the crank trigger, even with the guy im doing it for standing there saying "it wont be that, the engine was only rebuilt 1200 miles ago". looking at the trigger sensor and seeing witness marks from something hitting it.  i tried using a 3SGE dizzy on a drill with the sensor taped on the side and instantly got a clean trigger pulse. managed to get a screw driver in the back of the timing hole and thats when i found the trigger wheel detached. it was just pure coincidence that the wiring loom had been cut through at the same time the trigger wheel failed. One of those things.. Next time im going right in for the trigger wheel first on one of these 2JZ-GTE non VVTi's ..
 

Link to comment
Share on other sites

  • 1 month later...

Update time.

So the supra runs. Starts well, idle is a bit lumpy, but then it does have stage 1 cams fitted. 

Customer has an issue where it doesnt boost past 4000rpm. Its a flat nope, hard cut when you plant or try and tickle it past. I know the ecu is set so it doesnt let you go past 4000 rpm till its above 80c. But even when hot its not behaving. 

Im fighting several small issues with this setup. I didnt get to install it, so finding out how the installer has done things.  Like how both turbo wastegates are plumbed into one vsv but the option to control boost is disabled in the link.  Or how its still running the stock MAP sensor and stock Brass Air temp sensor. Customer came back with "well could be the O2 sensor" not understanding its no longer using the stock O2 sensors and uses the AEM wideband instead. 

Going to do a laptop run out in it shortly and see if i can get some logs, but hoped the Guru being AdamW might have some peals of wisdom over it. Nothing else has been done to the map/tune since last posting it. 

Link to comment
Share on other sites

Is it factory turbos?  The whole sequential valve setup is overly complicated with several points of potential failure which is why 99% of people modifying supras go to a single turbo.

Link to comment
Share on other sites

sorry its been a couple of days since i last posted about this. not having the car readily available to work on is a headache.\

got a couple of logs. hopefully today i get to go out and do some driving logs of it. 

2 issues. boost and throttle hang. 

boost seems to just hard cut as it comes on. had a look and the tuners seem to have plumbed both stock turbo actuators into one turbo vsv. yet the boost control in the map says its turned off. not sure how they expect to control things like that. also the owner has said that boost control only works with one big single turbo. so much misinformation about things. customer didn't want to mess with the boost cause its got the ceramic impeller turbos. (apparently they are not in the best of health anyway according to the guy I'm doing this for.)
the throttle hang is the other thing. when you blip the throttle the rpm's hang afterwards. before settling down. its like it has an air leak. yet everything is tight. its still got the TRAC control throttle installed . but i have no idea if its wired into the Link. i doubt it. 
could still be fighting a wiring issue with all this and it have nothing to do with the Map or Link. apparently it was running fine before the customer took the car and then it died after the rh arch loom got eaten by the stupidly oversized tyre. that loom was repaired but there may be other issues. it also sounds like its missing a bit when idling. like its dropping a plug. yet new plugs and coil packs all tested good. 
trigger scope is nice and clean now. at least that headache is out the way.

supra hang time.llg supra hang.pclr Trigger Scope Log 2022-11-22 5;03;20 pm.llg

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...