Jump to content

Evo 4-8 Direct Spark Issue


Recommended Posts


I have just converted an Evo 6 with EvoLink 4-8 G4+ to direct spark, but it's not working.

In PCLink I have changed the spark mode to direct from wasted, moved the wires from Ign 3 (Pin 22, now Ign 5 pin 35) and Ign 4 (Pins 20, 32 & 34, now Ign 6 on expansion harness) and run in a new loom for coils 3 & 4 but the car will NOT start. It is as if the injectors and ignition are firing on different cylinders as there's plenty of popping out of the exhaust. When I refit the wasted spark harness and change the spark type back to wasted it fires up with no problems? The ECU is running the latest firmware.

I have checked and double checked the coil harness wiring and I am 99% sure it is correct (Each ignition output was put into test one at a time and a spark confirmed at that cylinder, then checked with a multi meter. + and - pins are stable at 12V, ignition wire to +12V fluctuates when in test) so after a couple of hours of testing and double checking I'm hoping that someone can shed some light on the issue?!?! 

The only odd thing I can could see in the base map settings are that the Evo 4-6 has a different trigger 2 setup to 7-9, however the cam signal is the same on 4-9, so why this difference of rising and falling edges? I have tried both settings by the way, and no improvement. 

I have already completed this exact same modification on a G4+ Evolink IX and had no problems at all. I've attached the Direct spark file (Car won't start) and a modified version of this file back to wasted spark that DOES start the car when the original coil harness is refitted. I am hoping I have missed a setting somewhere, I can't find it for the life of me.

Thanks :)


Ads Lambda1 DirectSpark_Wasted.pclr

Ads Lambda1 DirectSpark.pclr

Link to comment
Share on other sites

Go with the trigger setting that works for wasted spark.

As Adam mentioned you could be out by 360 in the timing offset which will give you spark but it will be on the exhaust stroke for all cylinders.


Link to comment
Share on other sites

Sorry for the delayed reply, really appreciate the fast response and advice. As soon as I can try it out I'll feedback the results......

FYI the car runs fine on wasted spark with either trigger settings of 'Evo 4-6', Trig 2 Falling, OR 'Evo 7-9', Trig 2 Rising. So far as I know 4-9 all have the same cam and crank sensors?

Link to comment
Share on other sites

  • 2 years later...

Been searching and though I’m running a vipec v44/v88 top board it was relevant to me 

I’ve change to direct spark and imported a dwell table to suit the coil packs. The car does run but now it very hard to get started  

I’ve set the trigger offset from 5 degrees to -355 seeing as it was probably 360 degrees out  

once it does get started from holding the throttle fully open it runs fine 


Any ideas why it would be so hard to get started now? 

Link to comment
Share on other sites

Thanks for the quick reply mate, spent a bit of time on it last night and as embarrassing as it is, I took a 12v switch to the relay which ended up having low power as crank so my ignition was extremely weak. Problem is solved but I’ve found another but that’s a temperamental wire at the ecu which I’m trying to trace. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...