Jump to content

Link G4+ Atom Vauxhall C20xe trigger problems

Micael Johannssen

Recommended Posts


I have installed the Link system into my super seven that has an old Vauxhall C20XE engine fitted.

I am running the engine with all orignal injectors, sensors and ignition. The Link system wired in. The engine has the original 60-2 with VR sensor for the crank pos and a hall sensor on the distributor. Now to my problem, I can not get a signal from the VR.

It is from the Bosch motronic 2.5 setup and worked just fine before. The VR sensor and the HALL sensor both has a three wire connection. 

I have wired trigger 1 and trigger 2 to the signal on the sensors. sensor ground to the shield/ground. For the Hall sensor I wired +5V. 

What am I missing or doing wrong? When I crank the engine I can see no rpm reading.

Link to comment
Share on other sites

To get an RPM reading in the ECU you will need 'Trig 1 Signal' and 'Trig 2 Signal' to read Yes. You can check these in the Triggers/Limits tab of the runtime values window (F12 key to open).

If you are not getting Trig 1 Signal saying yes then I would check the values you have entered in the 'Trigger 1 Arming Threshold Table'. If you have these set to high in the 0 and 1000 RPM columns then the ECU may be rejecting the signals as noise.

Link to comment
Share on other sites

Thank you for the support. 

I did check the trig 1 and 2 Signal, they said no. I have checked the threshld table. It was at 0.5 and I have tested different values with no luck. 

I have no error codes active, injector test - all injector fire ok, ign test - I get at ticking noise ok. I cant get the engine to fire. What else have I missed?

The VR sensor worked fine with the Bosche motronic 2.5 ecu, so did the hall sensor for the cam pos. If I have wired them wrong, would I get an error code?

Br Micael

Link to comment
Share on other sites

Here's how I would attack this; I would set Trig 2 to "none".  Set Fuel mode to "multipoint group".  Set Ign mode to "wasted".  Then at least that narrows down your diagnostics to only one of the triggers.

If you then still don't see RPM, then try swapping polarity on the VR sensor.  If it still wont register RPM after these steps then you are probably going to have to get a scope on the crank trigger to see why it doesn't like it.

PS. also check ECU hold power is not active.

Link to comment
Share on other sites

Thanks for the help.

I did just that and still no signal. Then I took a close look at my wiring and realised that I had trigger one wired with trigger two cable and vice versa.

I changed this and :)  I had signals, both from crank and from cam sensors. A clear step in the right direction. The engine did not want to start

I am running a setup with ITB and will not be able to use a MAP or similar. What is the correct settings to run with only TPS, temp and RPM?

Link to comment
Share on other sites

TPS for the main fuel table vs RPM if you can get any form of map signal you can then use this as an overlay table.

Be sure to do a timing calibration as timing could be anywhere if you haven't.

Link to comment
Share on other sites

From what I can see the C20XE is naturally aspirated, so also set the 'Equation Load Source' (in Fuel Main) to Load=BAP.

Now you have the triggers reading ok are you getting rpm showing in PCLink? If yes then the next step will be to use a timing light to establish the position of crank, cam and TDC on cylinder 1. You do this in ECU Settings > Triggers > Calibrate.

Edited by Scott
Link to comment
Share on other sites

It going forward...

I have both triggers saying yes, no trgger errors. I have rpm read during cranking, it doesent show emediatley, takes a couple of seconds then about 200rpm.

I even had the engine cough one time. Tested with strobe light and ignition lead for first cylinder. I had steady ignition firing cyl one.

Then I stated to fiddle with settings, trigger offset aso...then no more light signal from strobe. I tried the -117 in offset.

Gave up on cranking, need to charge the battery. Will give it another try tomorrow. 

Link to comment
Share on other sites

Glad to hear you have it running, well done.

The PCLink help file contains a lot of information on the settings, and does give some guidance, but is not a step by step guide. One resource you might consider is the G4+ tuning course offered by HP Academy, this is a video tutorial series and we've had a lot of good feedback on it.


You are welcome to keep asking questions here as you tune.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...