Jump to content

Impossibly small numbers on my fuel tune. Help please.


Recommended Posts

Firstly, my first attempt at modeled fueling . I am having to input ridiculously small fuel numbers for the engine to even start and idle. I am sure something is not correct somewhere .

RB motor, 3.4 l stroker from Spool. DW1000 cc injectors, base fuel pressure of 3 bar. DBW (Thunder ecu) Doubt this should influence anything but running a Kinsler mech fuel pump , see no fpr creep due to volume back pressure at idle or medium revs. (2x separate returns for surge tank and fpr)

Inj dead times as per DW spec sheet. Modeled info may or may not be correct - I do not know what some of the specs of our fuel is here and I have taken Link data semi assuming that fuel-95 octane-should be pretty much the same. I have dropped the fuel cooling effect down to 8 deg at this stage as I really need to get the motor running before doing the whole fuel cooling exercise thing . Not going duel fuel at this time. One issue I have is that DW injector sheet shows testing flow is 711cc/min @ 3bar test pressure. I have set this up at 711cc and tried 1000cc . Not much difference in results.


Attached my file .

And a small log file......mmm, exceeding 6.02 M file.

COVID APRIL S14 RB 34 new Layout 2.pclr

Link to comment
Share on other sites

Need to see the log, but 3 things that initially jump out at me from a quick look.

  1. MAP & BAP are very different - They should be identical with engine off.  That suggests your MAP calibration is wrong.
  2. In fuel settings your Min Effective PW is set to 0.97ms - You could possibly be sitting against that at idle so fuel table has no affect.  Try it at zero.
  3. Your Fuel pressure sensor calibration is unlikely correct.  The 7 Bar calibration is for the Link 7Bar MAP sensor. 

Also, You have gear shift cut set up to DI1 which is ignition switch.  It would pay to turn gear shift control and traction control off until you have the tune working right.

Link to comment
Share on other sites

(711gm/min)/(0.745g/cc) = 954cc/min.

I would suggest you set your injector driver settings in the ECU to 2A peak, 0.5A hold and then use the Type A data since it follows a more predictable curve.

Still, I dont think this is the main cause of your low VE numbers.

Link to comment
Share on other sites

Yup, agree totally. I seem to have a Honeywell 0-16 Bar fuel pressure sensor fitted !! Always worked well with my ViPEC V88.I think a big problem here is is related to this sensor as well.

Thanks for the info though, enlightenment when you cannot see the trees for the woods anymore....Ill load logfile this evening.

Link to comment
Share on other sites

Adam, I was under the impression that Thunder can do ecu/laptop comms at the same time Can is active ? I know my Vipec could only do one at a time.

I am using An14 for fuel pump control, could not get it to activate, do I need to supply Plug D with 14V separately for this function to work ?

I will still post Log files , I am re checking all my hardware first.

Link to comment
Share on other sites

CAN has nothing to do with laptop comms, both the Thunder and V88 can have CAN working at the same time as the laptop.  If yours doesnt it would suggest you have the serial wires connected in the CAN connector which will interrupt PC comms.


2 hours ago, Gsab said:

I am using An14 for fuel pump control, could not get it to activate, do I need to supply Plug D with 14V separately for this function to work ?

AN Volt 14 is an analog input.  Do you mean Aux 14?

Link to comment
Share on other sites

Yea,  sorry. Aux 14.

I am using my old Aim dash which has the round can plug fitted. Just beneath the comms plug. I am not using the dedicated can hi and low on plug D. If this is connected, I lose comms to laptop ie: disconnect.

I take it then that I should rather use the dedicated Plug D can Hi and Low ?



Link to comment
Share on other sites

5 hours ago, Gsab said:

I am using my old Aim dash which has the round can plug fitted.

That comms plug is fine to use, but you just dont want any wires connected to the 2 RS232 pins.  If you have comms interupted then it means you have something connected to those pins 5 & 6.  What does the cable look like that you are using? Is it the CANF plug or one of our our CANDASH cables for the old Link display?  

Make sure you have no wires connected to pin 5 & 6 and it will work fine.



Link to comment
Share on other sites

I went and read ALL 206 pages and all the topics in this forum. Yes, it is a lot !

What I found was that most of the questions asked are pretty much the same issues, just in a different format.

Same problems. Adam, you are a Trojan mate ! Putting up with the same stuff ad infinitum..

I really learnt a sh*tload of how the ecu works and how the features inner working are interlinked. I am sure I still now very little but was able to help myself.

I also discovered that Adam no longer works for Link, that's a double kudos to you for handling a large part of this forum bud.

The biggest thing I saw was that there was no acknowledgement for Adams or any other persons input, advice and problem solving. Once the answer was given, hardly a reply or  thanks. An eye opener.

I have solved all my immediate issues( I hope) and thanks for your input Adam , CJ , Vaughn and others ! Thanks guys, it is appreciated greatly .


Link to comment
Share on other sites

@Gsab I've been visiting this forum every day for a couple of years now, and have been reading every new thread that's posted, and I agree - you can learn a LOT about how the ECU works just by doing so, and also HUGE respect to @Adamw for his professionalism and patience (even when he didn't work for Link for a while - I think he's back officially now?) - especially when, as you said, most people do not come back to say thanks!

It reminds me a little of this:


XKCD: Wisdom of the Ancients


One thing I don't like about Haltech is that they discourage you from using the forum, and prefer you to call them. That means as a new (or potential) user, you don't have the ability to look back over issues people have had and see their resolution, so it's likely you'll make similar mistakes to others.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...