Jump to content

Internal logging issue

Recommended Posts

I have an issue with the internal logging....Often after the track session (15 min) , i try to download internal logging file and i see they are stopped automatically..

This is very a bad issue because in the most of track session i don't have the ecu log to check after the race.

The log stop automatically and random before the internal memory is full

I attach  a log file downloaded after 14 minutes of track race..the log record only the start 4-5 minutes and after stop

I have used as start condition for the log, a 1800 rpm engine speed


Link to post
Share on other sites

Hi Tim, we have also experienced this issue of random deletion of internal log files.

Last month, we attended an even which involved 8 separate runs around a track. We trigger internal logging with a switch wired to a Digital Input (so we can see that it is 'on'). For each of the 8 runs, we would switch it on, do the run, then switch it off. At the end of the event when I checked the logfile, there were only two runs recorded - very annoying. It was the last two that were recorded, indicating that the ECU just deleted the logfile at some point after the 6th run, and all we were left with was the last two.

We then did exactly the same event this month, and all 8 runs were recorded perfectly. Go figure...

Link to post
Share on other sites

I think there is a bug causing this as it has been mentioned a few times before.  When I was at Link we tried to reproduce it for quite some time and never could so it makes solving it pretty difficult.  I suggest you email your tune,logs and a bit of detail to tech@linkecu.com just so it stays on their radar and more files from more users may hold a clue.  

I have a few customers that I regularly view logs for after a race meeting and it has never happened to me yet.  I usually have logging running all the time however (no conditions) and usually delete them after I download. 

Link to post
Share on other sites

Yes I believe there's a bug too.

I have a custom dash that I've configured to flash at me when Log Memory use is < 5%.  Therefore, when the memory becomes erased, it flashes at me and I know the instant it's become erased.

It must have happened to me over 20 times (in 2 years) and every time, it's when starting engine, as confirmed by the subsequent internal log file always starts with ECT showing 'cold'. 

Should it have become erased right at the end of the previous engine running time (not during starting as I suspect), the ECT would have shown 'hot'.

I don't have a log file to hand, however, the resulting new logs have always looks completely normal.

The only part I'm not 100% sure about is, whether the erasing takes place during Key-On or Cranking.

Hope that all makes sense!?

Link to post
Share on other sites

I will Chime in and say that this has happened to me many times.  Ill go to a drift event and drive the better part of the day and there is hardly any logged data.  My internal logger is triggered by rpm/tps conditions.  

I dont have near as much info as Tim but having the dash alarm to show when it has happened is a great idea that I would like to implement.  Care to share some details there @Tim D?  I gather its just config the ecu and dash for log memory on a CAN channel?

Link to post
Share on other sites

Interesting to hear that a few others have experienced the same problem.

I will email tech support as Adam suggests.

To add to my previous findings, I believe logging always works properly (rather than it failing to log for a period of time, which could easily be assumed), it merely gets erased.

Brad, you are spot on with your assumption. To elaborate, I've configured CAN2 to stream 'Log Memory Use' and configured my Dash to  'flash at me' if 'Log Memory Use' < 5%.

I designed the dash myself so have complete freedom to configure it as I wish, but I suspect the ECU could be configured with some conditional logic (I've never tried this) such that any dash could display the info?

I was going to attach my .pclr but get the following message:

You are only allowed to upload 81.92kB

Can someone at Link help resolve this please?

Link to post
Share on other sites

This log erasure issue has also happened to me several times.  When I have a log it is fine, but occasionally (1 in 15 or 20 sessions) I attempt to download the log and the only thing there is from Key-On to download the file.  I download the log after almost every track session (I may not after warm up or qualifying which are short sessions.)  ECU logging is always On.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...